Please register or login. There are 0 registered and 1112 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s December 17 - 02:54am EST 
Hardware Analysis
      
Forums Product Prices
  Contents 
 
 

  Latest Topics 
 

More >>
 

    
 
 

  You Are Here: 
 
/ Forums / Hard Drives /
 

  Getting rid of "A Disk Read Error Occured. Press CTRL+ALT+DEL to restart" error. 
 
 Author 
 Date Written 
 Tools 
Continue Reading on Page: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, Next >>
Ben Pruett Feb 09, 2005, 02:35pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
I got this error when installing XP on my old machine. XP partitioned, formated, and copied the files. After rebooting I got this message...

NTLDR: couldn't open drive,multi(0)disk( 0)rdisk(0)partition(1)

This is the same problem (previous post in this forum included below) with an older COMPAQ 5000 series (5BW160) previously posted. The problem ended up having a very simple solution. I had accidentally switched the IDE cables so that my hard drive was reading as a secondary drive. Designation in the BIOS as "Secondary Drive" clued me in. Simple enough. All I had to do was switch the IDE cables and XP setup continued fine.

Anyhow, not sure exactly what raymond meant by unplugging the power and keeping the IDE cable connected. Hope this helps if you're putting XP on an old Compaq.

------------------------------------
PREVIOUS POST:::
------------------------------------

raymond brooks Jan 17, 2005, 10:56 PM


Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
hi all, i have had this problem for a couple of days and finally got it worked out...

for those of us running into this problem using an older COMPAQ or other OEM built machines don't give up hope...

i just got xp up and running on this old Compaq 5000 series (5wv254) this is what happened to me....

i started out by formatting and repartitioning the harddrive after booting from my windowsxp disc... i got the first error a day ago after my first attempt to reboot after the Windows installation files had been copied and after "Your system will reboot in 15 seconds" message.

at first i was getting the NTLDR: Couldn't open the drive message... so i did a search for the error and found that many people with the older Compaqs were having this issue as well as the "a disk read error occurred" error. i tried going into the recovery console and repairing the installation serveral times only to be met by one of the two errors. so i would simply do another repartition, full format, etc... but kept getting the same errors.

i eventually started paying closer attention and saw my harddrive was being recognized as drive (1) instead of drive (0) after typing diskpart in the recovery console and in the system information in the Compaq bios... this was the problem after all. i played around with the ide cable - i had the drive on the end connector on a dual cable like it should have been but it was still showing up as drive (1). i even changed cables with the same result.

so i remembered a little trick and went inside the pc and unplugged the power cable but kept the ide cable connected and powered on the system. after this the drive changed from drive (1) to drive (0) on primary master. at this point i had already copied the files to the harddrive using the winxp cd for the fourth or fifth time. so i tried to just reboot since the drive was now showing up in the right place however, i then got a different error during setup "something like the drive may be damaged or something".

this wasn't good as i thought since everything was in its rightful place that setup should have run just fine. so now i'm thinking the drive was definitely bad as i had originally suspected anyways. instead of giving up i tried to repartition and reformat (full) one more time and this time i got past the a disk read error occurred press ctrl alt del to restart - it went straight to the blue setup screen!

so at those with the older compaqs don't give up too soon like we all consider doing after so much time with an older pc - i think there is something going on with the compaq bios that sets the drive to drive (1) instead of its proper place (drive 0) and this is the problem. just make sure you try a differnt ide cable > unplug the power with the ide cable still connected to the drive > the start the pc a couple of times > then shut down and plug the power connector back in > then go into bios and see where the drive is showing up. if its showing up on drive (0) you instead of drive (1) you now need to go through the whole repartition, reformat (full), and setup again with the drive in the correct position.

a couple of things as a side note....

1) there is an issue with the cdrom or more likely the ide controller (like someone else mentioned a little while ago) on these compaq oem machines. for some reason the internal cdrom dies and just stops during the copying of the setup files and you get random "unable to copy xxx.xxx file".

to fix this issue i connected an external cdrom and everything went very smoothly from there on in.

good luck to all and don't give up... read the whole thread and try different possible solutions AND POST YOUR RESULTS IF YOU GET SOMETHING FIXED... only forum trolls come in for solutions only and doesn't post their successful results to try and give back after finding a fix for their issues.

don't be a forum troll - take a few minutes and share the good fortune


Want to enjoy less advertisements and more features? Click here to become a Hardware Analysis registered user.
koden koden Mar 04, 2005, 04:35pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Mar 26, 2005, 03:57pm EST

 
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
I have a Seagate 160 GB with the same problem. I will look the thread, and try some of it. And then return.
For me it hapent without any warning.
Had just shut down my PC and turned it on again. DISK ERROR it says......
And I have done nothing before this. Just used my computer to surf the net

My drive is 0 in bios, so thats not the problem for me

By the way....I have and older compaq P3 800Mhz.

I'll be back :-))

25032005 i'm back :-))

In bios i set my HD to LBA, and my problem is gone.....I can only see 137 GB of my 160 GB disk.
But I new that before, so thats okay.
But the error is gone... yuippeee.. :-)))

Tyler Bradley Mar 05, 2005, 01:34pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
ugh. i dont know where my XP disk went. and im having this problem. the only reason that im typing this is because i happened to have a knoppix disk near the computer. my friend said i had no bootable partitions. HELP

Robert Lafayette Mar 09, 2005, 12:08am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
I have two IBM THINKPADs with identical specs.

They are both 600, oldies but f*cking work horses.

One has a 4gig drive and the other a 20g that i bought, both travelstar.

The 4gig can go into either machine but the 20gig gets the DISK READ ERROR on the other notebook.


I think its quite retarded!


NTFS is the file system on the one that can do both machines so I will now go ahead and FORMAT FOR THE FAT LOVERS!!


Alright guys I'll post in a minute.



Tim Motsam Mar 09, 2005, 06:22pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
I think I have the answer to this. It is a memory problem, not a disk problem. That is why it is happening with different operating systems and new installs on different drives. It is either actual memory errors OR timings set too agressive for your memory in the bios.

I had this same problem with 4 different brand new SATA drives. I returned the first two for new ones and got the same problems.

Next I downloaded a free memory testing utility called Memtest86+ from memtest.org. It is a very small ( 43k) file that creates a bootable floppy disk. You boot with this disk and it THOROUGHLY checks your memory.

It found over 300 errors on one brand new Kingmax 512mb PC3200 chip and 21 errors on the second chip. I returned the chips for new Mushkin memory, found no errors with memtest86 and now have NO MORE HARD DRIVE ERRORS!!


BJ Mellon Mar 12, 2005, 10:05pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
AAAAAAAAAAAAAAAAGGHHHHHHHHHHHHH!!!!!!!!!!!!!! I've had my computer for 3 months now, and i've had nothing but problems ALL caused by windows! I have a 120gb maxtor. Today, i was using my computer, and suddenly, nothing would open it would say "cannot open" "would you like to send an error report?" I hate windows sooooo much! so i restarted and a blue screen came up. on reboot the stupid error came up. if i can ever get into my computer, the first thing im going to do is install an operating system that DOESN'T suck.

raymond brooks Mar 12, 2005, 10:59pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Mar 12, 2005, 11:02pm EST

 
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
to the guy that mentioned memory - it very well could be that the memory still stored in the memory chips could be causing conflicts with the XP?

anyone know if this is possible?

BJ Mellon Mar 13, 2005, 10:20am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
well, i am completely stuck. the widows cd doesnt work, it just goes black and thats it. the maxtor diagnostic utility wont work because it doesnt support my hard dirve controller. AND, not even knoppix works, it just locks. so i have no idea what to do.

BJ Mellon Mar 15, 2005, 08:23pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
does anyone know of a program that i can use to copy all my files off my HD onto another? i was able to run checkdisk, and my drive is now accessable, but i want to back it up, and i am getting a new hard drive because im scared of this happening again. thanks.

J B Mar 19, 2005, 05:30am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
Have 2 Drives
- Maxtor 20GB
- WesterDigital 160GB

My motherboard is so old that my WD is only recognized as 33gb, so my task included...

1) Using 6 floppies for the windows xp home ( http://www.microsoft.com/downloads/release.asp?releaseid=33290 ), I initialed a fresh install on a Fat32 file system on my old 20gb, with the 160gb NOT plugged in

NOTE: Before when I tried to use just the setup CD for windows home install, the computer would hang. It seems the floppies setup program fixed that for myself. Also, the floppies contain tools to do an actual NTFS format/partition unlike my Windows Home Install CD (it's a custom from Cicero, the company who made my comp)

2) After a fresh install, I shut the computer down. I had an issue where I could install windows on a NTFS system, yet as soon as I shut down the computer I would get drive errors (if i restarted the computer, no errors...weird), , so I opted for the Fat32. So after shutting down, I start up and make sure I can get back into windows (so I don't waste my time finding out my drive is messed after I add patches, shutdown and reboot)

3) Install all required updates, including service pack 2

4) Once again, shut down computer and make sure no drive errors when I start it up again (restarts don't seem to work). I usually leave it off for 15secs.

5) Shut down the computer again, attatch the 160 as slave or primary (won't matter if you boot from the CD for step 6)

6) Reboot, insert my Western Digital Data Lifeguard Tools CD and add the drive as a New Boot Drive. In my case, I used a 160GB Fat 32 partition. The tool will format and create the partition and do a direct copy of all files from the old to the new drive

7) After an hour or so, the copying is done, and I shut down the computer and remove my old 20gb drive. Set my 160gb jumpers to master (or blank) and reboot.

8) Enjoy the limitations of Fat32...sigh

When I try to do a "convert C: /fs:ntfs" on the 160gb, after reboot I get the Drive error, ctrl+alt+del...blah message, so yeah that's basically the problem I'm having.

My best guess would be that my master boot record (the western digital drive overlay) was installed on fat32, yet now the system is using NTFS, so it incompatible. However fixmbr/fixboot and all those other lovely tools seem to do squat.

I'm getting a new mobo/processor/memory early next week. If that allows me to do a NTFS partition on my 160, I'll post back here. I'm guessing it won't though

G LP Mar 21, 2005, 05:07pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
Read whole thread... my scenario was using a 2.5 notebook harddisk as a secondary drive as needed to recover data for client. Added as a secondary HDD using a IIDE to 2.5 Laptop IDE Cable. All cables and power fine as already had a secondary harddisk I knew worked. I was unable to control notebook HDD by jumpering to be a slave device and normally this is not necessary. However on boot the above problem continual. I changed the BIOS setting to force IDE 0 instead of IDE 1 on secondary boot device (1st being floppy) even though on motherboard it says IDE 1 and secondary device plugged into IDE 2. Sorry if this is obvious to anyone else, but now BIOS reads IDE 0 and secondary IDE 1 I am able to boot and read the laptop harddisk as another disk and recover data. Now that I am able to do this I am running an anti-virus on it and have found the inevitable problem for the laptop not booting in first place... Number of trojans!! I am yet to finish fix for laptop but this problem did start after client told me he had left laptop on for over 24 hours too in standby/hibernate which I advise all clients to not do especially with laptops. This still could prove to be a hardware problem but the Disk read error Ctrl-alt-del was definately IDE number assigning in BIOS. Thanks for all other entries.. By the by it wasn't the answer but am pleased with the Recovery console and chkdsk /r idea. same for MBR. Cheers

BJ Mellon Mar 21, 2005, 08:19pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
For those of you who cannot use the xp cd because the screen goes black, i have a solution (at least it worked for me).

1. hook up some old hard drive. make sure its big enough to put all your files in. (preferably an ide not sata, so you dont have to install the drivers for it later on)

2. install xp on the drive. (the xp cd should work. if not, pull out the broken drive and try it)

3. once in windows, install the drivers for the sata controller. reboot. (if your drive is not connected, shutdown, and connect it.)

4.when the computer boots back up, it will (hopefully) run a program, i think checkdisk. that will allow you to access your hard drive. (this could take a very long time.) It should recover all your files, but delete most system files.

5. When you get into windows, copy everything over to your old ide (just in case)

6. the hard drive probably isnt permanently broken, and at this point you can reinstall windows. (I wanted to be safe, so I used the powermax utility that you can download at the maxtor website to do a full low level format before I reinstalled windows. This changes all 1ís to 0ís on the disk)

7. After that, you just copy all the stuff back onto the drive and you will be fine.


Also, I figured out what caused this to happen to me. I was overclocking, and forgot to set the pci lock. Since most onboard hard drive controller run off the pci bus. Running the pci bus frequency above 33.33mhz can be very dangerous. It can cause hard drive corruption. If you want to overclock, make sure that your motherboard has a pci lock. If not DO NOT overclock. Unless of course you want this to happen every week.

Hope this helps, and good luck!

-micah k.

Greg Gilmore Mar 26, 2005, 02:06am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
I do this for a living and this Compaq 5WV254 almost got thrown out a window. My client wanted XP put on the machine and as soon as the reformat and XP started it's initial install and reboot the good old NTLDR error came up. After an hour of trying to figure out why the drive was being read as drive 1 vs. drive 0 I found a rom update which took care of the problem. If you go to Compaq's site and type in the model number you can get the update. The file is called SP18768.exe, just follow the dir. Hope this helps you out there.

Jacee lala@lala.net Apr 01, 2005, 03:07am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
Ah, the joys of working on OEM products, bring the good ol DOS days back. Yes, the first solution worked for me. Im sure I know why the Compaq machines put the drives second on the first controller. By default they leave the hard drives on "cable select" Which is suppose to be the "plug and play" Uh, what I meant to say is ... "plug and pray" of master/slave configuration. They tend to use the slave portion of the IDE chain which of course is going to assign the drive as second. To fix this issue just set the jumper on the drive to master and move the IDE cable to the other connector. It worked for me, thank heavens for forums. This would have baffled me for some time if these help topics weren't available.

THANK YOU!!!

C G Apr 07, 2005, 01:51am EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Apr 07, 2005, 01:52am EDT

 
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
I have a slightly different problem -- Compaq Presario 1950 (I think) laptop, circa 1999/2000. I was getting ready to plug in the backup HD when I started hearing knocking from the HD. System was frozen. Turned it off, waited a while, turned back on and got this exact same error.

Original OS was Win98, upgraded to 2000 eons ago. I'm thinking the HD is dead; don't have the CDs or disks to boot from, either. Anyone have suggestions -- I really need to recover this data ASAP! (I was working on my taxes when this died -- no chance for backup, and my other computer is an iBook. Sigh...)

Thanks!

J B Apr 07, 2005, 12:43pm EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
Okay, it's weird. I posted above that I had errors working with my 160GB WD HD, where after I installed and rebooted, I'd get the error.

Now I finally got a 137GB NTFS Partition working, and it's been stable for the past 2 weeks. I can't tell you specifically what I did to get it working, yet here's a few steps I took.

1) Made sure I had the correct jumper settings on my HD. I had it to none, yet then for good luck, I just made it master
2) Formatted my HD using the windows boot disk (this is a non-service pack boot disk I'm speaking of)
3) Used the Datalife guard tools to great a 137GB NTFS partition
4) Rebooted and used the 6 floppies I downloaded from microsoft to initiate the install
5) Installed windows, rebooted to make sure I didn't get the HD error, then installed SP2 through the FREE CD-ROM (just search for sp2 at microsoft, and they'll get it to you in a few weeks)
6) Enjoy 4GB+ files :)

Seems rather simple doesn't it? It did NOT work for me when I tried this several times before hand. I think the key feature change was step 1, because even with my new mobo/memory/cpu, my drive would still be recognized by windows setup as 33GB. The next time I installed with the jumper settings, it read it perfectly...so I recommend you all try this out first

G LP Apr 07, 2005, 12:45pm EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
Just finished working on a disk crash, pre-empted by the tale tale clicking noise crash then nothing. Removed disk and attached as a slave to a know good environment. Could get nothing off. Disk definately dead. Not confirming or otherwise in your scenario as I would need to run the same test, I only offer a solution to your most dire question of data recovery.... try http://www.disklabs.com/ . Get a quote.. if they don't get the data they don't make you pay.

Good luck

G LP Apr 12, 2005, 04:14am EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
To the chap who wants to recover his data i.e. his accounts; I have found a more reasonably priced website than my previously posted Disklabs which quoted £512 personal data recovery and £765 business recovery (not sure it should make a difference being that both are to recover data on IDE drives that have failed!!, but apparently there is a difference in the form of £200 or so!!) You may instead want to try http://www.easyrecovery.co.uk/Hard_Drive_Recovery.htm who are doing a deal for £249.99 No fix no fee. Hope this helps.

Sally Kentfield Apr 15, 2005, 10:09am EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
Hi one and all,

I'd never come across this problem before, and I've worked on a lot of computers, until a friend recently asked me to help with their computer.I agree with most of the posters that the only common thread seems to be "Windows". I read all the posts, and tried many of the suggestions.

When re-installing, I found that Windows would install and load with NTFS format IF I deleted the partition, recreated it, and then ran a full format (not a quick format). I then created a boot disk (just in case!) containing boot.ini, NTDETECT.com and ntldr. On the next reboot, the same old Disk Error message appears. I tried booting from the boot disk, and that, quite interestingly, didn't boot the C:\ drive, but did bring up a "HAL.dll files is missing" message. This seems to corroborate the theory that the error is HAL-related.

I then installed XP Home with a 10Gb primary partition formatted FAT. On reboot, still the same error message.

I then went in to the BIOS and disabled the PCI IDE Busmaster. Rebooted and WIndows loaded okay.

So, it looks like it is a combination of HAL and Bios/MB settings. I would therefore surmise, in line with other suggestions, that there is something in the Bios or MB settings that the HAL in WIndows is looking for, and (in the case of an Asrock K7Upgrade-880 MB), the solution seems to be FAT partition, max of 10Gb, set Bios to no PCI IDE Busmaster.

Vladislav Staroselskiy Apr 15, 2005, 03:20pm EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Apr 15, 2005, 03:55pm EDT

 
>> Re: A Disk Read Error Occured. Press CTRL ALT DEL to restart
Argh ! I had a hard time to figure out exactly, what is going on. it took few days, but finally, I did it.
I've got the same problem as all of you and didn't want to simply reformat partition and install XP over without knowing what caused this problem.

Shortly - it says, what it says, "disk read error". It means, that you either have problem with HDD controller,
BIOS IDE settings, IDE cable or HDD itself.

Here is the long story:

Motherboard - Intel D850GB motherboard with latest BIOS (P18)
HDD - Seagate Barracuda ST3200822A.
HDD has one big NTFS partition (200Gb), that was created during XP setup.

My XP was working fine, then I suddenly got "Disk error" message after reboot.
I performed the following:
1) Tried XP Recovery console. fixboot, fixmbr, chkdsk /r, chkdsk /p. Replaced ntldr, ntdetect, ntoskrnl. No effect at all.
2) Disabled IDE busmastering in BIOS. Played with IDE HDD settings. No effect.
3) Reflashed BIOS firmware, cleared CMOS (reinstalled battery). No effect.
4) Tried Testdisk 5.5 ( http://www.cgsecurity.org/testdisk.html ). It says "partition size appears to be too small", I guess it doesn't work with such big partitions.
5) Tried standard Seagate Tools ( http://www.seagate.com/support/seatools/ ), downloaded from their website. Got results, that physical disk state is OK, but "something wrong" with NTFS. I guess, it also doesn't check fine big NTFS partitions.

And, finally, started disassembling NTFS bootblock to see where the problem is...
Thanks to Bootmaster creators for useful disassembled code with comments ( http://bootmaster.filerecovery.biz/appnote3.html ), Ralph Brown for Interrupt List ( http://www.ctyme.com/intr/int.htm ) and Hiew author for useful asm editor ( http://webhost.kemtel.ru/~sen/ ).

I found, that error appears when INT 13H/AH=42H function (EXTENDED READ) is called - at 010AH address. It usually returns "0" on success in AH register and some code when error appears.
I temporary changed NTFS bootblock code to see what exact error it gives and found, that
it returns 3FH code in AH register, which is not in <a href="http://www.ctyme.com/intr/rb-0606.htm#Table234">standard error codes list</a> (!!!).
It seems, that Intel BIOS programmers used some undocumented error codes... :(
At least I was not able to find them in Internet.

Then I tried to hook up this HDD to another computer with ASUS motherboard
and it booted fine, like there was no problem at all - I could not believe it !.. 8-()
it seems, the problem became BIOS-dependent...

Then I downloaded, installed and executed HDTune program ( http://www.hdtune.com ).
While doing "Error scan" I noticed a lot (millions) of "Raw read Errors" in
S.M.A.R.T. information (Health tab of HDTune). It seems, all of them were
"ECC hardware corrected" though, since "ECC correction" counter has the same
number as "Raw read errors". It seems, that my HDD started dying...

And, finally, I got the idea of having undocumented 3FH error there.
Seems, some of the BIOS'es (from my Intel motherboard) check S.M.A.R.T.
counters within Interrupt 13H and return error code when counter number
appears to be out-of-range. Some of them (like ASUS) - perform call function only
and don't check S.M.A.R.T. information at all (or, probably, have other less strict criterias for it), so, it is working w/o any visual problem on them.

I wish that some BIOS developers would confirm it.

I am doing backup of this HDD now, then I am going to create RMA and replace it.
I also blame Seagate for having so nasty HDD checking SeaTools.

Just my 2 cents to community... :)


Write a Reply >>

Continue Reading on Page: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, Next >>

 

    
 
 

  Topic Tools 
 
RSS UpdatesRSS Updates
 

  Related Articles 
 
 

  Newsletter 
 
A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.