Please register or login. There are 0 registered and 1335 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s December 17 - 10:07pm EST 
Hardware Analysis
      
Forums Product Prices
  Contents 
 
 

  Latest Topics 
 

More >>
 

    
 
 

  You Are Here: 
 
/ Forums / Games /
 

  Problem with "the battle for middle earth". Help! 
 
 Author 
 Date Written 
 Tools 
Continue Reading on Page: 1, 2, 3, 4, 5, Next >>
Sebastian Veloso Dec 28, 2004, 05:11pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List Replies: 85 - Views: 57692
Hello, i have a problem with my game.
When i start the game, it goes for the presentation, or trail of the game.
Then when it starts loading before it goes to the menu it crashes and automatically quits the game.
An exception message shows.

It gives me some words like EXCEPTION_ACCES_ VIOLATION. then says: The thread tryed to read from or write to a virtual adress for which it does not have th appropiate access. Access address 0x00000030 was read from.

Another paragrph then say:
Location: 4fe74e72(uknown module)

Version: release.

Then it gives a stack trace. After this messages it gives the options of Debug break or OK.

After clicking on both, and error message appeared:
Title: Microsoft Visual C++ Runtime library
Body: Program:...Files/EA GAMES/The battle for middle earth(tm)/ game.dat
This application has requested th Runtime to terminated in an unusual way.
Pleas contact the application support team for more information.
Options: OK

I really don{t know what happens. A friend of mine install this game with no problems.
Please need help. Thank you for reading and sory for my bad english i am from Argentina.
Thanks


Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
Sebastian Veloso Dec 29, 2004, 01:29am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
MY specs are:
Pentium 4 2.8
2 x 256Mb DDR kingston, dual channel
Ati Radeon 9600 XT 128Mb
Motherboard: Intel D865PERL

Michael A. Dec 29, 2004, 10:09pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
This is a rare problem as several Google searches turned up nothing but this thread. My first suggestion is to try completely removing and then reinstalling the game.

Michael A.
Website: http://itnode.net
jonathon weiberg Dec 31, 2004, 12:12am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
I Have That Same Problem And I Tried Lots Of Things.Sad To Say None Of Them Worked Nor Made It Run Longer.Mine Plays The Game But Bombs Out In 10 Min Or So.I Emailed EA!Im Going To Try Reinstalling The Game.If You Find ANYTHING Out Let Me Know.

Sebastian Veloso Dec 31, 2004, 11:32pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
Now i am in vacations but iun 3 days i wwill go to my house. I will install it again and tell you the news.
Happy new year. Send me news if u have one of the problem. Thanks

haste nichtgesehen Jan 01, 2005, 08:36pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
Hey guys. I got the same problem with lotr battle for middle earth. I start playing it and after some time (up to 2 hours) the game crashes. I think its a hardware problem (maybe configuration of RAM). It could also be that i can play the game longer than you because of my 768mb memory. If anyone knows how to fix this problem please tell us immediantly!!!
(I don't think the problem will get fixed with reinstalling)

My Computer:
P4 2.26Ghz
ATI 9800 SE 256Mb-RAM
1x256Mb-RAM + 1x512Mb-RAM
160 Gb-HDD S-ATA Samsung
MSI 848P Neo-V Mainboard

jonathon weiberg Jan 03, 2005, 08:40pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
Hello,

Thank you for contacting us here at Electronic Arts Technical Support,

This error means that you need to get the Platform Unified drivers from nVidia's site for your Sound Card, it is already too old. If you may check the date of the driver, it was dated, 2002.

Thats The Reply They Gave Me See If That Works For You Im Going To Try It Right Now!

Chris Miller Jan 04, 2005, 12:54pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Jan 04, 2005, 12:55pm EST

 
>> Re: Problem with "the battle for middle earth". Help!
It seems we all have the same problem. Read Below.

Every time I go into Lord of the Rings: Battle for Middle Earth, I try to start a game and I get into the game. It seems to work fine until I move the mouse to the edge of the screen and then it freezes. I dont know why. If you could help me with this issue please be prompt. Thank you.

My system Specs:
Averatec 6100 Series
3.0Ghz P4 w/HT Technology
768MB of PC2700 DDR Ram
ATI Raedon 9600 Mobility w/64MB of DDR Ram
Sound: Realtek AC97 Audio
Direct X 9.0C installed and Service Pack 2 for Windows XP Home
All drivers are up to date and Windows Certified.
No Hardware Conflicts.

Again there are my computer spec, I would appreciate prompt help for this issue. Thank you.
~Christopher Miller~

Nathan Peters Jan 04, 2005, 11:27pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Jan 04, 2005, 11:39pm EST

 
>> Re: Problem with "the battle for middle earth".
I contacted EA as well regarding two similar errors. Both different types of access violations. I know this game is based on an updated C&C Generals: Zero Hour engine and if you search for "serious error" and "zero hour" i'm sure you'll find a host of problems that EA never fixed. I can only assume that the updated engine contains these same errors to some degree.

Anyway, EA told me my problem was basically sound related. I have a computer less than a month old. Here are the specs before i go any further.

AMD 64 FX-55
MSI NForce3 NEO 2 Platinum M/B
1G OCZ 4200 EL DC DDR Platinum (2x512)
Sapphire X800 XT PE
SB Audigy 2 ZS Platinum Pro
2x SATA in Raid 0
DX 9.0c / WinXP SP2 (all updates)

Now, before i got my audigy 2 installed i was using the realtek '97 soundcard that was integrated in the m/b. When i first contacted EA they said it was sound related and my drivers were too old. They just well might have been. I was asked to lower hardware acceleration on the sound card, update the drivers etc. Nothing helped. Then a week later i installed my Audigy 2. I updated the drivers straight away and disabled all other sound devices and i still receive the same error, with the same frequency.

As for the amount of memory allowing longer gameplay, on the various Zero Hour forums i encountered, it was stated that the Zero Hour engine had a problem with memory leaks. However, i have 1G of memory and i can *still* crash out of the game after only 10 minutes of play (this is after a cold boot). Although i find it possible the memory leaks may have carried over to the *supposedly* updated Battle for Middle Earth engine, obviously it's not the only problem (besides, even on the ONE occasion i did manage to run the game for a full session lasting easily 4+ hours, i never encountered any slowdowns or anomalies i could liken to memory leaks).

This is the last piece of correspondance between EA and myself, after all their "soundcard suggestions" failed miserably.

/snip

Thank you for contacting EA technical support. I am sorry that you are having difficulty. I noticed you had Service Pack2. We are currently looking into the various issues regarding SP2 and our games.

Microsoft covers several of these on various pages throughout their database.

http://search.microsoft.com/search/results.aspx?st=b&View=...amp;qu=sp2

I have looked over the system information included with your email and it appears that you are in need of an updated driver for your video card. Go to the following website and folow the simple instructions to download the latest drivers. The following instructions are solely provided as a general guide as each manufacturer may utilize a different method for installation.

/snip

I keep all of my hardware updated, so it seems their suggestions of updating drivers is just a way of saying "we really don't have any idea how to fix it" .. or perhaps "the real solution is so embedded that we don't want to expend the resources to fix it".

Sadly, the Zero Hour people (and there were quite a few of them with a similar error) had been campaigning for over a year on one board with many different attempts at resolution, none of which seemed to work.

Now, onto the one occasion i mentioned above where i did get the game to work for an entire session. (Keep in mind that normally i can rarely get through a single mission, even if i rush, without crashing out of the game with this error) One of the suggestions was to enable compatibility with Windows 98 for Zero Hour. A few (very very few) people seemed to find this to actually work for them, unfortunately Battle for Middle Earth will not run in Windows 98, but i did attempt the game in Windows 2000 compatibility. Now i can't remember exactly what else i did (there was more i'm certain, because just using the Win 2000 compatibility option alone doesn't seem to work) I have since tried disabling everything in the background TSRs etc (Antivirus, Firewall etc etc) and i still can't reproduce it. It may have been sheer luck but i still run the game in Win 2000 compatibility mode on the off chance it will work again. (Hell i didn't even want to STOP playing once i got it to work, fearing i may never have the opportunity again .. but the real world had to come and interfere). Anyway, one constant that i seem to have noticed is that with one save game i have, i load it up and can guarantee an error somewhere in the 5 minute mark. (most times it seems the error is random, could be 10 minutes in, could be half an hour, could be 5 minutes, but this could also be because of different maps / units / etc).

I do own Zero Hour and i'm almost tempted to install it and see if the error message pops up for me with similar frequency. Unfortunately for such a great game (being a LOTR fan) it's sad to find such heartache getting to the good stuff. By the time you build up your base and resources in a skirmish game for example, you usually crash before you get to do anything exciting.

Anyway, that's my take on this problem.

EDIT: I can see some of you using WinXP SP2, just curious if we all are or not. Please post your Operating System and Service Packs (if applicable). Anyone tried this on WinXP SP1?

Zak Zak Jan 05, 2005, 01:39am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
Hi, I have the same problem as all of you, but since I did some changing in the OPTION menu of the game, the problem stopped.

Go to Option and under Audio option do the following :
- uncheck EAX3 box,
- uncheck HIgh Audio Quality box

The sound in the game is still not bad, better doing this till they find a patch then rebooting each time

Kim Seang Jan 05, 2005, 01:41am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
The game runs find on my system, only the occasional lag becuase of my card.
Here's the spec:

1.47 GHz AMD
512 RAM
80gig HD
Geforce FX 5200 128DDR

and I don't even run service pack, just xp by itself.

Maybe you guys should uninstall service pack and see if it works.l

tom coster Jan 05, 2005, 10:24am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
yea i have the same probem infact i have both problems and its driving me mad. It will either close the game and give me the EXCEPTION_ACCES_ VIOLATION error or the game will totaly lock up an i have 2 reboot. i find the EXCEPTION_ACCES_ VIOLATION better coz no rebooting involved lol. Im gona try the sound thing 2 c if that works.

My specs are:
p4 3.06ghz prescott (50 load)
512 mb ram
abit A17 MoBo
HIS Radeon 9600xt 128mb

colin steel Jan 05, 2005, 04:51pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Jan 06, 2005, 05:10pm EST

 
>> Re: Problem with "the battle for middle earth". Help!
Hey ppl.

I have a similar problem

I spent all of my money on LOTR: BFME I installed the games with out any problems at first. I did the tutorial and it was looking great with no problems. Then i played the game and it appeared ok but it suddenly crashed after 15 mins and i got some violation message. My father installed it on his computer which is fairly inferior to mine and it works perfectly. I came to this site and tried some of the suggestions (increasing the paging file size to 1 gigabyte, uninstalling sp2 and only having sp1, unticking the two boxes in the audio options) sad to say none of them worked.

Please, please! If there are any other ways to fix this, help!!!!!


~Thanks in advance

jonathon weiberg Jan 05, 2005, 04:59pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
The UNIFIED Driver Update Fixed My Problem Here Are My Specs

Amd Athlon 64 3200+ 2.4GHZ (Overclocked)
1gb Of Ram
100GB Harddrive
Nvidia Nforce Sound Card (Onboard)
Maddog Nvidia Geforce 256mb Agp 8x Video Card

Sebastian Veloso Jan 05, 2005, 06:12pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
Hello
I am Sebastian, the aregntinan boy that started this forum. I could resolve my problem.
The thing was that i went to ati´s webpage and i download a CATALYST Windows XP 4.12 - Driver Download

Here is the web page:
http://www.ati.com/support/drivers/winxp/radeonwdm-xp.html

I had also to download for me this to work:
Microsoft’s .NET Version 1.1 Framework

webpage:
http://www.microsoft.com/downloads/details.aspx?FamilyId=262D2...laylang=en

Thanks to all for trying to help. thanks
Seobis


p.d. Sory my bad english

Kim Seang Jan 06, 2005, 12:08am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
Guys just use windows xp without sp1 and see if it works becuase it works for me.

tom coster Jan 06, 2005, 10:59am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
i have the latest ati drivers and all the lated drivers 4 my bios I also have sp2. so i cant c y its happening because my drivers are not out of date. But it is possible it is a compattibility issue with sp2? I ceem 2 be getting a bunch of errors with this game :(.

Sebastian Veloso Jan 06, 2005, 07:09pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
if u have ati products please enter de links that i put in my last post.
Seobis

jonathon weiberg Jan 06, 2005, 10:33pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
Iv Been playing the game for a while and it really has dumb things in it.Helms deep for the evil side for example is so gay the people of rohan attack you!Also you have to WAIT for reinforcments GAY for the evil side!!!!!!!!!!!!!!!
Good side helms deep is pretty good.
Another bad thing is that in the middle of the evil campeighn u kill the heros.They seem to come back to life in helms deep wtf is up with that.

Technical error wise W0W iv seen so many errors while surfing the web.

Battle for middle earth = HuGe dissapointment.

George Culverhouse Jan 09, 2005, 07:50am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: Problem with "the battle for middle earth". Help!
Hi!
I have installed battle for middle earth on my dad's laptop but i seem to be having the same problems as some of you.
Sometimes it just crashes after about 10 mins or sometimes an hour. I think this is just because laptops are not as fast as pc's. But my real problem is with my pc. I have a homemade shuttle X wich is a top of the range gaming pc. When I put the cd in, it autoruns but after i select what language i want the installation to run on it says please insert disk 1!?!?! Obviously the disk is allready in there but when i click ok it just says it again. (basically its not reading the disk) CAN ANYONE HELP PLEASE!?
George

tom coster Jan 09, 2005, 02:34pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Jan 09, 2005, 02:36pm EST

 
>> Re: Problem with "the battle for middle earth". Help!
yep the crashing is a realy weird (pc specs^^) thing and its most likley EA's fault some where along the line. As 4 ure cd problem i might be able 2 help u. If u got 2 START > My computer > (right click) D drive > Open > lotrbfme_inst

once u double click that it should install and if it dont work take it bak and try another disc. And if that fails ure either screwed or need a new cd/dvd drive :P


Write a Reply >>

Continue Reading on Page: 1, 2, 3, 4, 5, Next >>

 

    
 
 

  Topic Tools 
 
RSS UpdatesRSS Updates
 

  Related Articles 
 
 

  Newsletter 
 
A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.