Please register or login. There are 0 registered and 1028 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s December 10 - 09:16pm EST 
Hardware Analysis
      
Forums Product Prices
  Contents 
 
 

  Latest Topics 
 

More >>
 

    
 
 

  You Are Here: 
 
/ Forums / Windows Vista /
 

  "Your searches might be slow because the index is not running" 
 
 Author 
 Date Written 
 Tools 
Feb 29, 2008, 01:49pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: May 07, 2009, 11:47am EDT

Replies: 16 - Views: 13073
Even with the new supposedly anti-monopolistic search features in SP1 due to Google's complaints, if you turn the Microsoft Search indexing service off ... everytime you do a search, you get ...

"Your searches might be slow because the index is not running"
http://img219.imageshack.us/img219/9918/vistzaindexer.png

... with no option to 'never show this message again.' :~

Oh my. Anybody know of a way to turn off that nagging message?


Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
BoT Feb 29, 2008, 03:30pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
turn the indexing service on. ;) kiddn

You can either be part of the problem or be part of the solution.
Codisha - http://www.codisha.com
Reviews - http://www.codisha.com/reviews/reviews.htm
john albrich Feb 29, 2008, 05:30pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Feb 29, 2008, 08:58pm EST

 
>> Re: "Your searches might be slow because the index is not running"
That's wonderful Vista for ya!

There's got to be a hack to get rid of the notice, somewhere.

Personally, I've never seen much search performance benefit in running with indexing on in any version of Windows, including Vista.

My solution to search performance issues was to switch from Windows Explorer to XYplorer (freeware version, of course).

Incredibly faster searches than Explorer, and I like the setup better. I do miss the thumbnails I had in Explorer and freeware alternative "xplorer2".

I now use XYplorer almost exclusively. When I absolutely need thumbnails, I use freeware xplorer2.

The paid XYplorer version has some nice added features (including thumbnails) and I'm really tempted.

http://www.xyplorer.com/index.htm
Vista compatible

XYplorer ver 5.55 is now available for free!
http://www.xyplorer.com/index.htm
Free as in: Fully functional. No nagging. No limitations. You may even use it commercially!


http://zabkat.com/
Vista compatible
Comparison of features at:
http://zabkat.com/x2lite.htm
Not sure if x2lite is Vista compatible




edit to add--Oh! Another very limitation (to me at least) in Windows Explorer...the maximum number of characters I could put in the search field was around 256 (a 2^8 restriction) (there are some really funky programming glitches that can reduce this number substantially, and/or cause search look-ups to report the wrong results, too)

With XYplorer, this limit is 1024 characters (including the ";" term separators) in the search field, and I've yet to see any programming glitches cause a problem.

BoT Feb 29, 2008, 06:49pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
i hardly had problems with windows explorer. it what i am most used too.
i also have had hardly any problems with the indexing service. it eats some resources
but not a whole lot and usually during idle time.

i am sure that there is a registry key/ switch that would eliminate this pop up

You can either be part of the problem or be part of the solution.
Codisha - http://www.codisha.com
Reviews - http://www.codisha.com/reviews/reviews.htm
BoT Feb 29, 2008, 07:35pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
i am not on a vista machine right now but i found this on an xp machine
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\MSIDXS ErrorLookup

dunno if that's it

You can either be part of the problem or be part of the solution.
Codisha - http://www.codisha.com
Reviews - http://www.codisha.com/reviews/reviews.htm
Mar 31, 2008, 03:23pm EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
BoT,

Tried it, not it. :( Still haven't found anything, so if anybody ever does figure it out, post away. :_) I'd like to know.

Apr 19, 2008, 12:20am EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
Well, I created a bit of a workaround-slash-crappy-hack. I began to wonder when I did a search, what was Explorer doing to determine if the Indexing service was running.

Turns out all it does is look to see if a service (any service really) named wsearch (the indexer service) is running. If so, ok. If not, nag my face off. :X

So all I did was delete the original Indexing service, replaced it with a dummy service named wsearch, started the dummy service and blamo! No more nag screens, and no more indexer eating up 50-100MB of memory! Yay! :cool:

BoT Apr 19, 2008, 01:21am EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
way to go, i'll say. i probably would have just renamed the indexing service instead of deleted it
but hey what ever works.

You can either be part of the problem or be part of the solution.
Codisha - http://www.codisha.com
Reviews - http://www.codisha.com/reviews/reviews.htm
Apr 19, 2008, 01:51am EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Apr 19, 2008, 01:51am EDT

 
>> Re: "Your searches might be slow because the index is not running"
Well, monkeyballz ... I found a downside to this. :(

When I have my service running, everytime I try to rename or delete a file, I think Explorer is trying to notify the indexer ... because it thinks it's running -- but my dummy program doesn't understand what it's saying (or won't issue a proper response), so the whole system freezes. :X That's an ever bigger mess than I had before.

Oh well ... back to square one. :~

Tim L Aug 31, 2008, 08:14pm EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
I think I found a solution. When it tells you "Your searches might be slow because the index is not running" just click on it to enable it, then remove all the folders from the Indexing Options list, then when you search it will tell you "Searches might be slow in non-indexed locations" then you can right click on that message and click "Do not show this message again". :)

Greg Deakin May 07, 2009, 08:51am EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\InfoBarsDisabled\
Reg_Dword: ServerMSSNotInstalled
Value: 1

May 07, 2009, 11:20am EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: May 07, 2009, 11:41am EDT

 
>> Re: "Your searches might be slow because the index is not running"
Greg Deakin (91080) said on May 07, 2009 at 05:51am PDT:
HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\InfoBarsDisabled\
Reg_Dword: ServerMSSNotInstalled
Value: 1

Greg,

Sadly, that did not work for me. The InfoBarsDisabled key was there, and I added the DWORD as supplied, but even after a reboot, that little message still appears while doing a search with the indexer off. :(

There was an existing DWORD in there (value = 1), LocationNotIndexed, which makes sense, since I clicked "never show this again" on that one a long while back.

Where did you even find that? I can't find any documentation on the InfoBarsDisabled key.

Mic Mac Jan 18, 2010, 08:35am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Jan 18, 2010, 08:37am EST

 
>> Re: "Your searches might be slow because the index is not running"
Just for all Windows 7 Users the reg is the same

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\InfoBarsDisabled]
"LocationNotIndexed"=dword:00000001

Jan 18, 2010, 12:11pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Jan 18, 2010, 12:14pm EST

 
>> Re: "Your searches might be slow because the index is not running"
Mic Mac (93295) said on Jan 18, 2010 at 05:35am PST:
Just for all Windows 7 Users the reg is the same

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\InfoBarsDisabled]
"LocationNotIndexed"=dword:00000001

Hi Mic Mac,

Welcome to HWA. :_)

I'm not on Windows 7 anymore, but that's not quite the solution I was after. In my post right above yours, you'll see I already tried that with no success. LocationNotIndexed only removes the infobar for Searches might be slow in non-indexed locations: %DIR% Click to add to index...

I was looking for a way to remove the infobar the appears during every search if you have the Windows Search indexing service disabled: Your searches might be slow because the index is not running.

drew drew Nov 26, 2010, 06:15pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
when the message shows up, right click on it and click 'dont show this message again' ;)

Nov 28, 2010, 03:05am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
Hey Drew:
McFly (52972) said on Feb 29, 2008 at 10:49am PST:
"Your searches might be slow because the index is not running"
http://img219.imageshack.us/img219/9918/vistzaindexer.png

... with no option to 'never show this message again.' :~

So ... yeah. I wouldn't have asked in the first place if it were that easy.

A moot point now anyway, I left Windows last year for Linux. :)

Mark - Jun 29, 2011, 12:53pm EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: "Your searches might be slow because the index is not running"
Does anyone know which DLL or file stores the message "Your searches might be slow because the index is not running"? I searched the Registry but it wasn't in there.

While it's not a solution, you could at least change the message to something that would bring a smile, such as "Hmm - exactly why is Microsoft so desperate for you to turn on indexing?"

The best solution has already been mentioned: use Ubuntu Linux instead.


Write a Reply >>


 

    
 
 

  Topic Tools 
 
RSS UpdatesRSS Updates
 

  Related Articles 
 
 

  Newsletter 
 
A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.