Please register or login. There are 0 registered and 2826 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s October 27 - 01:31am EDT 
Hardware Analysis
      
Forums Product Prices
  Contents 
 
 

  Latest Topics 
 

More >>
 

    
 
 

  You Are Here: 
 
/ Forums / Hard Drives /
 

  WD SATA 120GB dead after 5 years? 
 
 Author 
 Date Written 
 Tools 
Nathan Cole Oct 05, 2008, 02:10pm EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Oct 05, 2008, 02:13pm EDT

Replies: 2 - Views: 2259
Hi, a friend asked me to help him after his Dell Dimension 8300 froze while browsing photos in XP and wouldn't boot thereafter. He's getting a Mac soon but at least wants to salvage his files. I figured it would be a simple fix, but...

The model is WD1200JD-75GBB0 120GB SATA rev A00 and it's his only hard drive. The system is about 5 years old.

On his system, the BIOS would go as normal (I checked that it could repeatedly auto-detect the drive) but then after a long pause with a blank screen, "A disk read error occurred Press Ctrl + Alt + Del to restart".

I first tried booting from the XP CD to try and repair the boot sector. It took quite a while for Windows Setup to load, but when it did, I hit R for the recovery console. After changing drive letters and trying to browse files, I realized his HD wasn't showing up. I booted from the XP CD again and this time pressed enter as if I were going to set up Windows. I wanted to see if Windows could detect any partitions on the drive. But it showed a table with four disk drive slots, all without a drive connected.

Of course I then remembered I would need the drivers, so after downloading Dell's 8300 SATA Promise drivers onto a floppy I loaded those in with F6. Then when I pressed R for the recovery console, it said there were no hard disks on my system and that setup could not continue. I tried again, loading the drivers and this time pressing Enter but got the same message (not even the table with four empty drive slots).

So, I downloaded the Western Digital tools for DOS onto a bootable floppy (Data Lifeguard it's called). I tried the Quick test which is supposed to take 5 minutes max, but after 15 minutes it still wasn't finished and I wasn't seeing or hearing activity around the drive and drive light.

Finally, I took the drive out of his computer and put it into mine (custom desktop, so all different parts from the Dell). I have 3 working SATA drives so I simply disconnected the power and data cables from one of my extras (not a system drive) and connected them to his. My BIOS also detected his drive correctly. But Vista took a while to get to the loading screen, and after about a minute even that disappeared and although there was activity on my HD light for the next 5 minutes I heard nothing. I tried twice more and Vista never loaded.

Finally, I tried booting from the Data Lifeguard floppy but after the message about Caldera DOS loading... nothing but a black screen. I couldn't even run the diagnostic tools.

So I swapped the cables back to my drive and everything works as before.

Anything I can do to try and get his files back or is it time for the fire/earthquake/flood professional recovery types?


Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
mothow Oct 05, 2008, 04:25pm EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Oct 05, 2008, 04:26pm EDT

 
>> Re: WD SATA 120GB dead after 5 years?
Im not sure if you can get the info off the HD with any software available to us but i know it can be done

ASRock Z97 Extreme 4 / i7 4790K / Corsair H80i / 4x4GB Crucial Ballistix Smart Tracer DDR3 1600 / 1TB Western Digital Caviar Black / 240GB Mushkin Chronos Deluxe SSD / 2x Evga GTX 670 FTW 2GB in SLI / Sound Blaster Recon3D Fatal1ty / Corsair HX1000w
Nathan Cole Oct 05, 2008, 07:29pm EDT Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: WD SATA 120GB dead after 5 years?
If that could do the job, it would be great, he really doesn't care about the drive itself. But would that kind of software even be able to recognize the drive when the WD diagnostic can't? So far only the BIOS seems to know the drive exists!


Write a Reply >>


 

    
 
 

  Topic Tools 
 
RSS UpdatesRSS Updates
 

  Related Articles 
 
 

  Newsletter 
 
A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.