Please register or login. There are 0 registered and 1119 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s December 10 - 07:24pm EST 
Hardware Analysis
      
Forums Product Prices
  Contents 
 
 

  Latest Topics 
 

More >>
 

    
 
 

  You Are Here: 
 
/ Forums / Linux /
 

  MBR+GRUB=Not Working 
 
 Author 
 Date Written 
 Tools 
olvrdh Nov 16, 2008, 10:11am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Oct 17, 2010, 01:55pm EDT

Replies: 5 - Views: 1873
Hey all,
I have two HDD's, on the first of which I have one partition with Win XP on it. The second HDD has three partitions on it in which I wanted to install openSUSE 11. I have sdb1 at about 200MB set to /boot, sdb2 with 6144MB set to swap, and the rest (70something gigs) set to /. Now when I try to install openSUSE, it copies everything nicely, until it gives me an error writing GRUB, and asks me if I want to change the settings. No matter what options I choose, it always gives me an error. For some reason, though, it doesn't let me edit the MBR on the first HDD (sda), which the BIOS automatically boots from, thus booting to windows. So I guess I'm looking for a way to manually install GRUB into the MBR of sda, which is the exact thing openSUSE is not letting me do.

(Note: I am a complete newbie when it comes to linux commands etc. so please try to keep possible answers idiot-safe...)

regards


Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
Reason   Nov 16, 2008, 06:47pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: MBR GRUB=Not Working
I'm no linux expert either but don't you have your boot and swap partition sizes reversed? I know when I partitioned for Ubuntu 8.04 I just did the full boot plus 1 gb for swap.

_________________
Ultima Ratio Regum
Sam Jackson Nov 17, 2008, 01:54am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: MBR GRUB=Not Working
Remove all your partitions first. Does SUSE give you a partition manager at install?

Anyway, just create a small partition and set it to swap. And leave the rest as /
The installer will do the rest and make any changes needed to install grub.

I hope. I've only tried fedora and ubuntu.

:D

olvrdh Nov 17, 2008, 02:04am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Oct 17, 2010, 01:55pm EDT

 
>> Re: MBR GRUB=Not Working
Well, I've tried deleting my partitions and letting the setup manager do it on his own, but that doesn't work; I still get an error message. When I then tell him I want to change the boot-manager settings manually, he pops up an error message saying something like "cannot install boot manager properly because of partitioning"

regards,

Sam Jackson Nov 17, 2008, 02:05am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: MBR GRUB=Not Working
What exactly is the error it gives you?

Adriano Pedro Dec 29, 2008, 01:46pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: MBR GRUB=Not Working
Did you set up your /boot partition with the flag bootable option ??

try to create only two partitions, 1GB for swap and the rest for the /

try to post the error message.


Write a Reply >>


 

    
 
 

  Topic Tools 
 
RSS UpdatesRSS Updates
 

  Related Articles 
 
 

  Newsletter 
 
A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.