Please register or login. There are 0 registered and 619 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s June 26 - 04:18am EDT 
Hardware Analysis
      
Forums Product Prices
  Contents 
 
 

  Latest Topics 
 

More >>
 

    
 
 

  You Are Here: 
 
/ Forums / Windows 7 /
 

  .jpg openning with explorer.exe WTF? 
 
 Author 
 Date Written 
 Tools 
Archangel Jul 22, 2010, 04:00am EDT Report Abuse
So i was playing around and i set .jpg images to open explorer.exe ( i was thinking it'd open them in their own explorer window )

Well it f**ked things up. Now when i double click a jpg it starts spawning about 50 explorer.exe processes per second and just eventually eats up all 16 gigs of my ram and makes the computer unusable.

Really freaking lame because now i can't change it back to something, every time i right click the file type and go to open with >> chose program, i can chose a program, but the ALWAYS USE THIS PROGRAM BLAH BLAH is grayed out. so i dunno WHAT THE f**k.

I also went into control panel and checked the default program for .jpg and its variation, they're already set to f**king windows picture previewers**t. i even set them to paint, photoshop. but nothing overwrites the explorer.exe setting. WTF!

I don't know what else to f**king try, i'm so p**sed at my self and this bullshit bug.


Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
~Vel Jul 22, 2010, 04:20am EDT Report Abuse
>> Re: .jpg openning with explorer.exe WTF?
That sounds like a mess. You already did what I would've thought to do. McFly to the rescue?

Afrow UK Jul 22, 2010, 05:01am EDT Report Abuse
>> Re: .jpg openning with explorer.exe WTF?
Go into regedit and open HKEY_CLASSES_ROOT. Look up .jpg (and .jpeg) and see what the OpenWithList and OpenWithProgids keys contain. The OpenWithProgids key especially lists the names of other keys under HKEY_CLASSES_ROOT that define how to open the file type. The only value in OpenWithProgids should be jpegfile. If you navigate to the jpegfile key (also under HKEY_CLASSES_ROOT) then you can manually change shell\open\command\(Default). It should be set to:

%SystemRoot%\System32\rundll32.exe "%ProgramFiles%\Windows Photo Viewer\PhotoViewer.dll", ImageView_Fullscreen %1

There should also be a shell\printto key and that's it.

Btw do this at your own risk I won't be held responsible if you f**k things up!

Edit: And the reason it's causing infinite explorer.exe instances is because passing a path to explorer.exe which isn't a folder just causes explorer to use the shell open command on it; which you have set to explorer.exe.

Stu

I like: Programming, Gym, University
Music: House, Dubstep, D&B, Trance, Metal


 

    
 
 

  Topic Tools 
 
RSS UpdatesRSS Updates
 

  Related Articles 
 
 

  Newsletter 
 
A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.