Please register or login. There are 0 registered and 1053 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s January 21 - 07:18pm EST 
Hardware Analysis
      
Forums Product Prices
  Contents 
 
 

  Latest Topics 
 

More >>
 

    
 
 

  You Are Here: 
 
/ Forums / Windows 7 /
 

  No option for "new text document" after making Notepad++ my default txt editor. 
 
 Author 
 Date Written 
 Tools 
Reason Dec 03, 2010, 12:04am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List Replies: 6 - Views: 2310
I didn't do a before and after, but the timing is too close to be coincidental.

I've googled for a fix and came up with this thread:
http://www.sevenforums.com/general-discussion/77402-new-text-d...ssing.html

There's a ZIP of a registry file linked on that page that helps you reset the default back to Notepad and fix the issue. However, I don't want to reset the default, I want to keep Notepad++ as the default. So I modified the last bit of the file from

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.txt\OpenWithList]
"a"="NOTEPAD.EXE"
"MRUList"="a"


I'm already nervous about mucking about in the reg, can anyone tell me if my modification will have... [gman] unforeseen consequences? [/gman]

to

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.txt\OpenWithList]
"a"="C:\Program Files (x86)\Notepad++\Notepad++.EXE"
"MRUList"="a"



_________________
Ultima Ratio Regum
Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
john albrich Dec 03, 2010, 05:41am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Dec 03, 2010, 05:43am EST

 
>> Re: No option for "new text document" after making Notepad my default txt editor.

Instead of messing directly with the Registry, have you tried using the "normal" way to set the OpenWith option?

Use Windows Explorer (or your favorite file management tool like XYplorer, Qdir, etc) to list any program with the relevant extension (e.g. ".txt")

Right click on the file (e.g. XYZ.txt), and select "Open With"
then select the "browse" option to find the relevant program (e.g. Notepad++.exe)
then check the box "Always use the selected program to open this kind of file"
then click OK

This should then allow you to verify you set it correctly by subsequently opening the file you selected with the program you selected.
(e.g. if you "right-clicked" on XYZ.txt, then when you click on "OK" it should immediately open XYZ.txt with Notepad++.exe)

If you want to see what happened in the registry when you did this, you can go to the registry and your change should be reflected by the addition of Notepad++ into the "OpenWith" list


There are also some freeware File Association "fixer" tools available for various versions of Windows. If you go that route, make sure the one you use is written for the OS you're using.

Reason Dec 03, 2010, 08:36am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: No option for "new text document" after making Notepad my default txt editor.
Thanks John, it's actually not a file association issue, it's this:

http://yfrog.com/75notxtp

There's no "text document" when I rightclick and go to New.

_________________
Ultima Ratio Regum
john albrich Dec 03, 2010, 09:32am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: No option for "new text document" after making Notepad my default txt editor.

It's interesting that the registry mods that you provided in the original post are the same ones affected by file associations.

What do you do to get-to/create that first window with the

View
Sort by
Refresh
etc

Are you starting out from within an app?

I'm also curious, did you notice the Text option disappear after installing OpenOffice, or has it always been that way on your system?

Reason Dec 03, 2010, 11:30am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: No option for "new text document" after making Notepad my default txt editor.
john albrich said:

What do you do to get-to/create that first window

Just a rightclick from the desktop, although I have the same problem inside folders/windows explorer.

john albrich said:
I'm also curious, did you notice the Text option disappear after installing OpenOffice, or has it always been that way on your system?

That's a good question, the installations of OO and NP++ were pretty close together. I wonder if it's a thing with OO.

_________________
Ultima Ratio Regum
Dec 03, 2010, 06:00pm EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List

Edited: Aug 06, 2011, 01:42pm EDT

 
>> Re:

Reason Dec 15, 2010, 10:28am EST Reply - Quote - Report Abuse
Private Message - Add to Buddy List  
>> Re: No option for "new text document" after making Notepad my default txt editor.
The .reg file referenced in the top post along with a reboot seems to have fixed it. I was able to reset my default txt editor to Notepad++ with no problems, so all is good.

_________________
Ultima Ratio Regum

Write a Reply >>


 

    
 
 

  Topic Tools 
 
RSS UpdatesRSS Updates
 

  Related Articles 
 
 

  Newsletter 
 
A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.