Please register or login. There are 0 registered and 297 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s August 04 - 06:14pm EDT 
Hardware Analysis
Forums Product Prices

  Latest Topics 

More >>


  You Are Here: 
/ Forums / Other Hardware /

  Delayed Write Failed / Error - FINALLY SORTED OUT! 
 Date Written 
Continue Reading on Page: 1, 2, 3, 4, 5, 6, 7, Next >>
ise piq Jan 11, 2005, 04:52am EST Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
It does not matter if you only formatted or partitioned a driver larger than 120 GB's. The Master Boot Sector or some such thing on the drive is still going to make it mess up if your MOBO or Controller Card does not handle today's larger drives.
2 More things that will mess up your drive this way:
1. You upgrade to SP1 or SP2 (W2K, WXP, etc.) OR do a repair install with not only an image drive or image drives installed, but DVD region killers too!!! DVD Region Free and Any DVD by Slysoft will do this!

Uninstall them, reboot your computer, make sure everything is fixed, then you can reinstall.

Another one! Do a search in your Registry for " noide ", (without the quotes of course). If you find this, do a registry save, then delete the whole line with 'noide' in it.

Basically now, there is a LOT of stuff you need to temporarily UNinstall BEFORE you upgrade your OS with an SP update, escpeciallly Windows XP SP2. Reinstalling them AFTER appears to work fine so far.

We must have about a dozen fixes in this list of posts so far now.


Want to enjoy less advertisements and more features? Click here to become a Hardware Analysis registered user.
Jason Ho Jan 18, 2005, 10:37am EST Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
Hello. I've recently encountered this 'delayed write error' with my 120g seagate HD connected via a lava external HD firewire enclosure. I've been using this drive for several years, but only recently, upgraded to a P4 (no VIA chipset), installed XP home and bought a new XFX GeForce 6600 video card. Neither of my 2 internal drives show the error.

After browsing through many of these posts, which I didn't have time to finish reading.. I thought I would start off with a suggestion from 'lava' the manufacturer of my enclosure before trying other posted suggestions:

This is what they suggest:
At times when using the FireDrive with Windows 2000 or Windows XP a "Delayed write error" will appear. This message may also be accompanied by corrupted or cross-linked files on the FireDrive's hard disk. To fix this problem, follow the steps below:

1) Enter the disk management utility which islocated under Control Panel >Administrative Tools > Computer Management.
2) In the right hand window, each of the drives in your system will be listed. For each one, right click on the drive and select "Change Drive Letter and Path."
3) In the window that appears, highlight the drive again and select "Edit" (or "Change" in XP). Leave the settings as they are and select OK (or Cancel in XP as the OK button is grayed out).
4) Below the listing of drives will be a graphical interpretation of the partition table. For each device (ie. Zip Drives, CD-RW, etc.) right-click and again choose "Change Drive Letter and Path" and then exit the window.
5) Reboot your computer and attempt a file transfer.

I honestly don't see what it does, since you don't select "OK" in XP, only 'Cancel'.

But it seemed to work for me. I don't know if this would be a solution for others who have a problem related to the external firewire enclosure, but thought I would post the solution to my situation just in case.

Hope that helps someone!


Peter Depacua Jan 19, 2005, 06:55pm EST Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
Hi Just thought I would let you all know my solution to this problem ended up being a full hard drive.
XP showed 11.gig of unused space but when I looked closer the drive was full. That particular drive is only used for storing data with no OS installed on it. What appears to have happened is XP has made a recycled bin on that drive and all the files within it were not registering as taking up space. Deleted them and the problem has gone. Sounds to simple but I had tried everything else that I could find on forums with no luck

Tom M Jan 22, 2005, 02:33am EST Report Abuse
>> Re: Delayed Write Failed
I'm having a problem similar to what has been discussed in this thread, but none of the solutions seem to apply. I am running Windows XP Home / SP2 on an IBM ThinkCentre, 160 GB hard disk (I can follow up later on the details.) Here's what happens when I try to boot:

In normal mode, it takes forever to reach the login prompt. After finally logging in, I eventually get a message saying "Windows Product Activation: a problem is preventing Windows from accurately checking the license for this computer. Error Code: 0x80090006", after which the system logs me off.

In safe mode, it's slow as a dog, I get various "Delayed Write Failed" errors, and the system eventually reboots itself before I reach the desktop.

In safe mode w/ command line, it's still slow, but I eventually reach the command line! I can run regedit, and explorer. But, after a few minutes, the machine reboots itself. However, it does stay up long enough for me to backup files onto a USB device. But everything is SO SLOW.

Any thoughts?


J Mit Jan 30, 2005, 05:21pm EST Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
Hey there,

I am having somewhat of a similar problem...I also had a question about a post earlier.

Someone mentioned about using a hard drive with a Promise IDE card. I have 4 hard drives, 1 250GB sata hooked into the motherboard, and 3 200gb western digitals hooked into my Promise TX2 IDE card. Now, when I hooked up my 200 gb hdds into the card, it would only recognize 137gb....but what I did was hook them up one by one into the motherboard, format them, partition and put them back into the ata card.

The card recognizes the 200gb but I am getting tons of Delayed Write Failed messages. Is it because of my ATA card not supporting the 137 GB barrier break?

Please let me know,

Xenos Matrix Feb 20, 2005, 11:23am EST Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
I do not think that this has any relation to the ATI Graphics card because I have an NVIDIA GeForce FX 5200 and I have this problem also. My motherboard is a VIA chipset and I get this problem only with my 80GB SATA HDD. So, all that being said, I think we can rule out the speculation that this problem is caused by ATI Graphics Card/MotherBoard incompatibility since my com has NVIDIA and has the same problem. We can also rule out the speculation that this has been cause by the 137GB barrier because my SATA HDD is only 80GB and I have this problem.
Therefore, it is most likely an OS problem or MotherBoard problem, regardless of which Graphics Card you use. I get the Delayed Write Failed error only when I'm using the drive with my PC. But as soon as I plug the thing into my Mac, I don't get such a problem at all. I can view all the files on the Mac and they all work just the way they're supposed to.
I recently visited VIA's website and downloaded their latest Hyperion Drivers for WinXP and another program called IDE Accelerator. After installing both, the problem went away and hasn't come back since. But of course, it could just be a matter of time before this kinda stuff happens again, as with all stuff relating to Windows.

Xenos Matrix Feb 20, 2005, 11:35am EST Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
I'm wondering why Windows is unable to support these kinda high speed reading/writing? How do they expect multimedia people and creative individuals to take them seriously when they fail at these kinda high speed stuff? I mean, no way am I gonna use a Windows to do my video editing if it can't handle high speed reading and writing. I don't have time to stuff my HDD into the freezer everytime it displays an error message. I think something has to bo done about this or Windows will not evolve into anything useful in the near future.
And if they keep on slacking this way, Linux or Mac is gonna crush them sooner than expected.

Bail W Mar 29, 2005, 02:29am EST Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
I want to ask how do i enter safe mode with *Asus P4C800-E-Deluxe*. because when i try to press F8. it wont give me the option to chose to boot up in safe mode. '


whoozee whatzit Apr 14, 2005, 08:12am EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
Try this on for size...

I received an error after a clean install of WinXP Home Edition, SP2, when I installed an iPod mini. The iPod mini is connected to the laptop via an Adaptec USB 2.0 pcmcia card. The darned thing slows the entire system down! All I have to do is simply unplug the iPod mini...and everything works just fine again. Here's the catch...the only reason I wiped-out this person's laptop and installed WinXP is because the iPod requires Win2k or WinXP on it. So yeah...the only reason I'm doing any of this is so my client can use her iPod. So unplugging it kinda defeats that purpose!!!

Any suggestions?

Srini S Apr 27, 2005, 04:05am EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!

I have a ASUS P4P800, P4 2.8, 80GB SATA and XP Pro SP2 .. no problems.
However when I use a 40GB Seagate harddisk in an external enclosure via USB 2 I get the "Delayed write failed error" when copying large files (> 700 MB) .. Read is absolutely no problem. The same harddisk on IDE works perfectly fine. The m/c works perfect .. the problem is with the USB hard disk ..

Any help or suggestions is appreciated ?


Jim Thompson Apr 27, 2005, 08:43am EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
I have a similar configuration and haven't had any problems since I installed the patch from Microsoft:;en-us;303013

Srini S Apr 29, 2005, 01:58am EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
No go :-( I installed this patch and the other windows patch mentioned in these posts on SP1 and no solution. Another machine on SP2 showed the same behaviour.

In fact all the solutions proposed in these posts were tried but no use. Iam at my wits end on how to write files to this hard disk.

Any other ideas ?


Arnaud Joakim Apr 29, 2005, 06:00pm EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
Here is my problem :

I bought a Maxtor DiamondMax 10 300GB 16MB Cache SATA coupled with a Silicon Image 3112A SATA Controller. I was never able to install Windows XP on this drive as it always crashed before the end.
I connect the hard drive to an existing Windows XP Pro SP2 installation and when i transfer any big files (500MB or more), i get the "Delayed Write Failed" error and the hard drive just disapears from windows! The drive reappears after i reboot.

What i did :

1- I spent hours reading all i could find about this error on the internet but no solution yet!
2- I updated all the drivers and BIOS of all my hardware but no change.
3- I returned the drive where i bought it and they did tons of tests only to return the same drive saying the drive was perfectly fonctional. So i guess the drive does not have any problems.
4- I thought it might be my Firewire controller because of Microsoft's article "885464", so i removed it from my computer but didn't change anything.
5- For the silicon image 3112 SATA controller, windows xp installed drivers version I updated to version and now instead of getting the "Delayed Write Failed" error, my computer just freezes and i need to reboot.

Some articles from the Microsoft Knowledge Base regarding the "delayed write failed" :

***;en-us;885464 <-- The symptoms are exactly what I'm getting but the HotFix didn't fix anything and i'm not using a 1394 Drive, i just have a 1394 controller, nothing connected to it.;en-us;330174;en-us;870894;en-us;842520

Exact error i get :

Windows - Delayed Write Failed : Windows was unable to save all the data for the file G:\$Mft. The data has been lost. This error

may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

From event viewer :
0000: 04 00 04 00 02 00 52 00 ......R.
0008: 00 00 00 00 32 00 04 80
0010: 00 00 00 00 9d 00 00 c0À
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........
0028: 9d 00 00 c0 box..À

When i look into my event viewer, these errors appear every time the "delayed write failed" occurs (in chronological order) :

1- "An error was detected on device \Device\Harddisk2\D during a paging operation." (SOURCE = Disk)
2- "The device, \Device\Scsi\SI3112r1, did not respond within the timeout period." (SOURCE = SI3112r)
3- "The system failed to flush data to the transaction log. Corruption may occur." (SOURCE = Ftdisk)
4- "The device, \Device\Harddisk2\D, is not ready for access yet." (SOURCE = Disk)

My configuration :

Athlon XP 2600+
2x256 MB DDR-SDRAM 333mhz (dual channel)
GeForce 6600GT
SB Audigy 2
MSI 6570 K7N2G-L NForce 2 Chipset
-Bios = v4.1 080204
Firewire PCI Controller
***Silicon Image 3112 revision 2 <-- SATA PCI Controller
-Bios = 4.2.50
-WinXP Drivers =
Maxtor 80GB IDE
Maxtor DiamondMax 10 300GB 16MB Cache SATA

I'm TOTALY desperate!!! Please, Anyone can help?? I invested a lot of money in this drive, and i can't get a refund so i need to find a solution! Thank you all for the help!


Trevor Hoppe May 03, 2005, 02:26am EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
Very similar error here Arnaud. Got a new SATA Controller and, similarly, the problem simply went from a Delayed Write Failed erorr message to a system hang. Attempted BIOS updates, driver updates - there's nothing left I can think of to update!!!

System hangs whenever I attempt large data moves.

Configuration: XP SP2, Intel 3.2 GHz, 2x512 DDR-II, GeForce 6600 GT, Gigabyte GA-8ANXP Duo Mobo, Silicon Image 3112A SATARaid Controller, 2x120GB WD Caviar SATA Drives.

Arnaud Joakim May 03, 2005, 01:40pm EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
Trevor, i see we have the same video card and same SATA controller. I don't think our video card is creating this problem but I wish i could try my drive on a different SATA controller, i don't see anything else, or Windows XP Pro SP2 has a problem.

You have the "delayed write failed" using either of your WD Caviar SATA Drives?? You don't have any other HDs installed? How are you able to use your computer then?

I've posted my drive on EBAY, so i got 7 days to find a solution or it will be sold. The more i wait, the less expensive this drive will cost so...

Keep me informed if you find a solution!

Trevor Hoppe May 03, 2005, 01:53pm EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
Well - I got very excited last night after I posted because I thought I had fixed it. Simply put the 2nd drive where I store most of my data on the mobo SATA controller and installed Intel Application Accelerator in Windows. Ran fine for 12 hours.... then DWF error again.

It only occurs when I do large data moves. I haven't done such a move on my 1st hard drive because I'm not particularly interested in having my entire system crash. I should probably just burn a DVD of all my data and bite the bullet and give it a shot. Just very frustrating to potentially have to reformat again.

Wesmosis kahlfalfak Jul 28, 2005, 10:06am EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
hey guyz
i'm having the exact same problem:
crashes and the Delay Wrte Error Message on Copy/Moving Large files
my HDD is Samsung 160 GBs , NTFS, No system files ,i.e for Data only
Have no ATI or RADEON .........I have Nvidia Vanta 16 MBs
Via chipset, k1 first Motherboard...........My LargeSystemCache=0 !
I'm using an ordinary IDE CABLE 40 wire - 40 pins, is it the cause?
I donno what's wrong?! guyz any help?
& what's the best software for Checking HDD for errors and bad sectors?

Steve Smith Aug 15, 2005, 05:16pm EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
I have a 40Gb USB2 HDD that kept getting the MFT error. After following lots of wild goose chases involving ATI and VIA drivers for my laptop, I found the solution and it's Windows-based.

(Note : This only works in Windows 2000 or XP as far as I have tested)

- Make sure the USB drive that's having problems is plugged in and you know it's drive letter
- Go into System Properties > Advanced > Performance Options > Virtual Memory..Change
- You should see the USB drive in the list
- Highlight your USB drive and you will see that there are no paging settings for that drive
- In Windows 2000, choose a reasonable initial size and maximum size (I use 200Mb - 400Mb) and click Set (you have to do this or the setting won't be saved)
- In Windows XP, you have the additional option of allowing XP to manage the paging file size. It's up to you which you want to use

And there you go. I instantly gained HDD stability and have now installed Virtual PC and have Ubuntu Linux running from my USB HDD!

Mathew Chow Aug 21, 2005, 08:34pm EDT Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
Need help regarding complete data lost after getting this Delayed Write Failed error.

I have a FAT32 17 GB drive in a Vantec USB external closure and after booting from the delay write failed error, Win XP would not recognize the formatted drive. The error has 'unformatted' the drive. Win XP would still assign drive letter and correctly identified the size of the drive but just failed to recognize the file structure. I tried a lot of the tips in the previous posts to no avail. Anything suggestion on what to try next? Or am I SOL? Thanks in advance.

Wim Jansen Jan 08, 2006, 10:59pm EST Report Abuse
>> Re: Delayed Write Failed / Error - FINALLY SORTED OUT!
I also had the DWF-error. I had installed a new Samsung SP2614 S-ATA drive. First month no problem. Then it started. Always while booting Windows and always on ev'ry partition of the S-ATA disk. I tried ev'rything, nothing worked. Then I read a msg somewhere of a guy that said Pinnacle Studio was causing it. I remembered that I had installed Studio about the same time the trouble began, so I removed Studio and I haven't had any DWF after. So it might seem rediculous, but it really works. Give it a try. What have you got to loose?

Continue Reading on Page: 1, 2, 3, 4, 5, 6, 7, Next >>



  Topic Tools 
RSS UpdatesRSS Updates

  Related Articles 

A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.