Please register or login. There are 0 registered and 889 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s August 12 - 04:26pm EDT 
Hardware Analysis
Forums Product Prices

  Latest Topics 

More >>


  You Are Here: 
/ Forums / Networking / Wireless /

  Problems with RPC Services -- Does not start. 
 Date Written 
SK V Feb 26, 2004, 02:40pm EST Report Abuse
Hi All,
In order to recover from a RALEKA.B worm, couple of days ago when I connected to internet, I disabled RPC Services and RPC Locator Services from Services MMC Console. When I was doing it, "Remote Procedure Call (RPC)" window mentioned that a group of dependent services will also be disabled.
Not knowing that RPC is a very essential service for Windows to function normally, I said Yes. I had problems restarting from that point on. However, I was able to tweak the registry settings for the "Remote Procedure Call (RPC)" and "Remote Procedure Call (RPC) Locator" and made sure they are set to Automatic and Manual respectively.

I am able to start "Remote Procedure Call (RPC) Locator" service from Services window. But when I try to start "Remote Procedure Call (RPC)", it complains :

"Could not start the Remote Procedure Call (RPC) Service on the local computer. Error 1058: The Service cannot be started, either because it is disabled or because it has no enabled devices associated with it."

When I try starting other services which are dependent on RPC, obviously, they would not start either. They say "Error 1068: The dependency service or group failed to start."

Everytime I start the machine (Laptop), after windows load up, it gives me "System error &H800706BA (-2147023174). The RPC Server is unavailable."

How can I come out this mess? What do I have to do to restore all my services normally, as I had before? I cannot connect to Internet, cannot browse files.

Please Help.

P.S. From all this, I learnt one basic rule: "NEVER DISABLE RPC SERVICES".


Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
Xemus Feb 26, 2004, 05:29pm EST Report Abuse
>> Re: Problems with RPC Services -- Does not start.
I got this from the ExpertsExchange forum:

Copy and paste the following into Notepad save the file and make the file extension .reg. Then go to where you saved it and then double click on it this should get the RPC place back into the registry and should hopefully get your RPC back.

Windows Registry Editor Version 5.00

"Description"="Provides the endpoint mapper and other miscellaneous RPC services."
"DisplayName"="Remote Procedure Call (RPC)"
"Group"="COM Infrastructure"




Michael A. Feb 29, 2004, 01:42am EST Report Abuse
>> Re: Problems with RPC Services -- Does not start.
Worth a try but I would back up my registry first if I were you.

Michael A.
Xemus Mar 01, 2004, 02:22pm EST Report Abuse
>> Re: Problems with RPC Services -- Does not start.
Sorry, i thought everyone knew that they should back it up before doing any major changes. :)

Variable - Mar 02, 2004, 05:47pm EST Report Abuse
>> Re: Problems with RPC Services -- Does not start.
When you used MMC console did you save the MMC file? If you did, and in that MMC console you clicked on it to disable RPC, it may be disabling it over the top of the normal computer management. I use the feature all the time to set up a fast internet firewall while using the web. Try this Start/Run type mmc and then enter, click the top CONSOLE and see if you saved a separate console. If you did just click on Add/Remove snap in then highlight the snap in and remove it.
You should be able to start and stop services easily through the standard MMC. If you cannot, its likly that either you have another MMC loading and running or you have goofed up your registry. If you do not know what your doing stay out of the registry, as a general rule.

SK V Mar 08, 2004, 04:10pm EST Report Abuse
>> Re: Problems with RPC Services -- Does not start.
Thanks for your replies.

I will try the registry option mentioned today. Thanks everybody. Specially Nemus.

Jeck Lamnent Sep 28, 2007, 10:39pm EDT Report Abuse
>> Re: Problems with RPC Services -- Does not start.
My system blue screened then after a slow boot-up I was in the GUI with a non-responsive start-bar, no audio, no networking. Just a couple 3rd party services loaded. I tried to start the usual ones and it failed. I couldn't get to the properties windows to check out more because no property windows would open on the system except for file/folder properties.

The base essential processes were loaded(csrss,smss,services.exe...) sans the usual collection of svchost.exe's.

I hopped into the cmd shell and checked for malware and ran across a nasty in my root and a collection of .exe files in my internet cache mascarading as .txt's and other types. I removed them all then rebooted and still nothing. I hopped into the registry and looked for odd services and found a few non-standard ones then deleted them then checked out my devices and found a malware hidden there so I deleted it too. Rebooted, still nothing...

I scanned all the .exes in the system folder looking for the system file checker and couldn't find it so I skipped that.

So I went back into the registry and deleted rpcss, more services; removed more drivers and still nothing worked.

I checked the file dates/sizes of svchost.exe, explorer.exe and a collection of other files that were under my magnifying glass and the dates were all fine but I had some bloated sizes so I hopped into my dllcache folder and used the copies there to overwrite the other ones. Still not working. I manually tried launching rpcss using net.exe and it failed so I tried launching it using svchost.exe and still nothing. I used one of my other systems to google this prob and nothing good was coming up but I found my system file checker (sfc.exe duh)

I set it to run on reboot and then rebooted and while it was scanning I opened compmgmt.msc and created a new user but couldn't open the properties to set it up so I hopped into my i386 folder and expanded the explorer.ex_ and svchost.ex_ and copied them over the existing copies. I then tried to start rpcss using net.exe and svchost.exe again (net start rpcss, svchost -k rpcss). When I looked at my other monitor at the task manager svchost was there! I then opened services.msc and turned on dns, dhcp, network connections and zero wireless and now here I sit :D I haven't rebooted yet but it working now and thats good enough for me.

These are the last things I did before it started to work:

1) Logged in, opened taskmgr (ctrl+alt+del)
2) Shelled to cmd and run (File menu, run, type cmd, clicked ok)
sfc /purgecache (type it and press enter)
sfc /scanonce (type it and press enter)
3) Reboot (Thru shutdown menu in taskmgr. You can also type shutdown -r)
4) Logged in, opened taskmgr
5) Opened cmpmgmt.msc (File menu, run, type cmd, clicked ok)
6) Opened Local Users and Groups, right clicked Users, chose create a new user...
7) Shelled to cmd and did these
cd c:\i386 (I can't find my xp install cd)
expand explorer.ex_ explorer.exe
copy explorer.exe %systemroot% /y
expand svchost.ex_ svchost.exe
copy svchost.exe %systemroot%\system32 /y
net start rpcss
svchost -k rcpss
start services.msc
8) Turned on dns, dhcp, network connections and zero wireless.

I hope this recipe for repairing it works for other ppl with the same problem.

Jeck Lamnent

Shane Oh Jun 13, 2008, 01:16pm EDT Report Abuse
>> Re: Problems with RPC Services -- Does not start.
SK V, have you figured out your problem yet? If not tell me and I'll help you.

Time Scream Jul 18, 2008, 11:55am EDT Report Abuse
>> Re: Problems with RPC Services -- Does not start.
I ran some of Jeck Lamnent items.. thanks Jeck!

Booted into windows
Opened DOS prompt
Via DOS, copied Explorer & SVChost from another xp pc, to a temp folder
Using Task Manager stopped the Explorer & SVChost processes
quickly copy the 2 files to the appropriate windows folders, using DOS to perform copy.
system auto rebooted

After reboot, issue still not resolved.

ran these via DOS...

sfc /purgecache
sfc /scanonce (system needs reboot to run)

I then ran this via DOS...

secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

Issue resolved!! Not sure if all the above had a role in fixing the issue?!?!
I also reapplied the service pack.

alessio barbagini Jun 19, 2010, 09:15pm EDT Report Abuse
>> Re: Problems with RPC Services -- Does not start.
hello my friends,

i hope u ok and happy, i founds theis forum in the net because i have a similiar problem.

i am sure that u r so far away more genius than me on the pc that id like u to help me.

i have this satellite toshiba and when in uni i installed (huge mistake bloody hell) a external soft to control the wireless because the antivirus of the wi fi in unu had something to do with it and without the software was not possible to go in net.

im sorry for the mess in the previous paragraph.

now i have the problem that the error 1068 come out all the time that i start zero conf, and so no wireless.

may u halp me to come out from this situation? really thank u in advance is all day that im try to see wat it is. i saw the dependences on the zero and in the rdl maybe have problem

thank u guys sorry for the bad english i tried my best, have a good day


bunty singh Sep 21, 2010, 12:00pm EDT Report Abuse
>> Re: Problems with RPC Services -- Does not start.
Thanks every body for this thread especially Jeck Lamnent. I was facing issues with RPC but I was able to solve it using Jeck's method.
Hence I have joined this forum and would love to be a part of this community.

af hoke Jun 19, 2011, 02:18am EDT Report Abuse
>> Re: Problems with RPC Services -- Does not start.
I had a similar problem (Taskbar not accessible, network connections disabled/missing, services won't start (in windows xp sp3)). I don't know what caused it, but Jeck's recipe fixed it. Thanks! I had been all over many different forums looking for solutions. By the way, I was a little nervous trying Jeck's solution since he said he hadn't rebooted yet, so it may be useful for others to know that the solution works fine, even after rebooting. In fact windows was working but looking kind of weird after applying Jeck's solution, but after restarting everything looks normal again.

I still wish I knew what caused this issue. Scanning for viruses now, but nothing yet.... The last thing I installed before the problem occurred was MS Visual Studio 2008 - not sure if that did it though.

Chuck Roast Oct 01, 2011, 09:09am EDT Report Abuse
>> Re: Problems with RPC Services -- Does not start.
I had a Rootkit virus recently and it was hard to get ride of, did though finally. But, using two programs to remove the virus, they had screwed up XP Prof. I couldn't connect to the net after getting rid of the virus. I looked at previous posts and tried Jack's recipe to no avail. I finally decided to repair XP by doing an install of it. I booted up my computer with XP in cdrom, selected install, not recovery console. After XP did some things, a menu came up, one for Repair which I selected.
What XP does is reinstall itself but works like an upgrade, nothing is disturbed on your drive(s). After you go thru the normal 'next' screen options at the end, oh btw, have your cdkey avail cuz ur gonna need it again. I finally arrived at the desktop.
Bingo, I automatically connected to the net. The repair install takes less time than a new install cuz all of your settings are unchanged. I had XP up and running in a half hour or less!
One final note, XP will update itself several times, let it cuz mine had '70' updates to install. After a reboot it installed '11' more. After a another reboot, '15' more were installed.
This may seem long winded but it is a hell of a lot easier than all the other posts involving the registry edits and so forth above.

Ken Partlow Oct 05, 2011, 04:54pm EDT Report Abuse
>> Re: Problems with RPC Services -- Does not start.
I have seen this on Winodws XP and more prevalent on Windows 7. What caused my issue was a security update. It was messing up the networking stack. I had to finnaly go into the update and run it manually and select Don't remind me again for this particular update. Unfortunately it happens periodically after MS weekly updates. MS has no answer for the issue except to remove the updates starting with the most recent and testing until the problem is resolved. They say it is a compatibility issue with some third party software that I use but cannot say what one it is. And it is not the same update all the time. But the results are the same, RPC locater error and no Internet/Network access. I removed the update that caused the problem and then had to go into safe mode and remove my network card driver and reboot. After the reboot all was back running like a champ again. This procedure worked for me but it may or may not work for everyone because the error can be caused by numerous variables and not every system is the same. So whatever works for you that is great but don't be mad if the same thing does not work in your case. Leave it to MS to throw a monkey wrench into our lives.

Dick Burton Oct 23, 2011, 09:51pm EDT Report Abuse
>> Re: Problems with RPC Services -- Does not start.
After doing some cleaning & uninstalling, with several different freeware programs, I ran into many problems when I started my laptop the next day >> NO SOUND; NO AUDIO DEVICE LISTED; NO TASKBAR; NO SEARCH; NOT ABLE TO INSTALL ANYTHING & probably many others...After trying many things & not knowing exactly what direction to take, I finally figured out that I did not have many services running; there was nothing listed in services under the "extended" tab; I was not able to start them manually & couldn't open "properties" >> kept getting an error re: missing dependency; Finally found that there was no "Remote Procedure Call" >>> I copied the Registry fix posted here, checked my Registry to verify that these items did not exist, backed up the Registry, installed the fix & re-booted and EVERYTHING IS BACK TO NORMAL >> THANK YOU, THANK YOU, THANK YOU....

Harry Frank Nov 09, 2012, 05:58am EST Report Abuse
>> Re: Problems with RPC Services -- Does not start.

Harry Frank Nov 09, 2012, 06:04am EST Report Abuse
>> Re: Problems with RPC Services -- Does not start.
I certainly admire the sender for writing out so thorough a registry entry. Perfect syntax, wonderful attention to detail, very clear instructions. Unfortunately, I found it perfectly useless because it is not in binary, and the error message I got when I double-clicked the document,per the writer's instructions, read,"You can only import binary files from within the registry editor."



  Topic Tools 
RSS UpdatesRSS Updates

  Related Articles 

A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.