Please register or login. There are 0 registered and 953 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s May 24 - 08:57pm EDT 
Hardware Analysis
      
Forums Product Prices
  Contents 
 
 

  Latest Topics 
 

More >>
 

    
 
 

  You Are Here: 
 
/ Forums / Other Hardware /
 

  "delayed Write failure" in WIN XP 
 
 Author 
 Date Written 
 Tools 
Continue Reading on Page: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, Next >>
Rhialto the Marvellous Feb 26, 2004, 08:20am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
You can read a test to sort out the Delayed Write problem in this thread http://www.hardwareanalysis.com/content/topic/22061/

Want to enjoy less advertisements and more features? Click here to become a Hardware Analysis registered user.
Michael Yeang Feb 26, 2004, 09:26am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
Thanks, John. I did not see "Edit Post" because I was not logged in!! Silly me! :o

Sean Patrick Feb 26, 2004, 07:39pm EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
I just thought I would throw my two cents in here and say what happened to me regarding this issue; which it seems like there is multiple issues in this thread, some not really all related. I was getting the "delayed write failure" usually as soon as I had a "good" working install in place. Usually for me the write failures would crop up once I started listening to my 100's of mb's of mp3's or if I started listening to streaming audio of any kind. Once the write failures occured I would have to reboot. Usually after a few days of this the machine became unbootable. I even sent a farily new Seagate SCSI 15,000RPM drive in for warrantly replacement thinking that was the problem. In the meantime I reinstalled the OS on another SCSI drive that was used before mainly as date storage. Not long after I had the install done THE SAME THING. The probablility of two drives failing in exactly the same manner is rather small. For awhile I thought it was SCSI card itself. REPLACED that. SAME THING.

Finally I cam across this forum and saw references to ATI video cards; which I have a Radeon 9500 Pro -- and the issue of the "large system cache". I enabled this tweak also via Xteq X-Setup. Short of the long story, I deselected the "large system cache" tweak via X-Setup and my machine is running perfectly. I've got an mp3 playing right now, multiple app's open, file sharing on, AND NO DELAYED WRITE FAILURES.

My relevant setup:

ASUS A7N8X-Deluxe (revision 2) nForce mobo
ATI Radeon 9500 Pro
Adaptec 39160 Ultra SCSI
4 Seagate Cheetah 15,000RPM drives
3 misc. hard drives (WD, Quantum, IBM)
Windows2000 SP4

I know this thread is mostly addressing WinXP, but the kernel/core of XP is pretty much the same as in Win2K -- as evidenced by nearly identical symtpoms and an identical solution.

Samson Eliaj Feb 28, 2004, 10:34pm EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
For those who have DWF and have a hardrive greater than 137 G or have just installed one ...and have problems moving files..try http://www.hardwareanalysis.com/content/topic/22061/ that
Rhialto the Marvellous mentioned above and upgrade ur ATAPI.sys file. This fixed my problem. Nothing else..registry settings, patches, etc etc did anything for me.

This is the most annoying thing i have come across and hope none of you have to suffer this like i did for over a month. I lost tons of data through corruption. So give this a try and see what happens

Erik Linde Mar 09, 2004, 08:09am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP

Mithrandir Greybeard Mar 11, 2004, 08:37pm EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
To Michael Yeang:

Months ago I posted about an issue with defragging a hard drive with goback. When it defrags the bin file a delayed write error may occur. I believe this was an issue with Systemworks 2002. You have to disable goback before defrag to avoid. I thought I would post again just in case this applied to you. Most of the threads seem to point to disk caching or ATI video software. I hope these issues are resolved because I want to buy an SATA drive with the 8MB cache in the near future.

NT Doc Mar 12, 2004, 02:54am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
Hope this helps others. If this does correct the issue for you then please post and say so one way or another.


My current %systemroot%\system32\drivers\atapi.sys
File version is: 5.1.2600.1106
Created: Thursday, August 23, 2001, 4:00:00 AM
Modified: Thursday, August 29, 2002, 1:27:50 AM

After running the Q331958_WXP_SP2_x86_ENU.exe HOTFIX the

IDE/ATAPI Port Driver ATAPI.SYS is now
File version is: 5.1.2600.1135
Created: Thursday, August 23, 2001, 4:00:00 AM
Modified: Thursday, October 24, 2002, 3:59:48 PM

Problem appears to be corrected... HOLDING MY BREATH!


Intel PIII 933 ATI Radeon All-In-Wonder 8500DV w/512MB RAM
Western Digital 250GB 8MB cache ATA HD

Operating System is Windows XP SP1 English all updates applied.

Currently applied hotfixes:
KB810217 KB810243 KB817778 KB820291 KB821557 KB822603 KB823182
KB823559 KB823980 KB824105 KB824141 KB824146 KB825119 KB826939
KB826942 KB828028 KB828035 KB829558 Q147222 Q322011 Q323255
Q327979 Q328310 Q329048 Q329115 Q329170 Q329390 Q329441 Q329834
Q331953 Q810565 Q810577 Q810833 Q811493 Q811630 Q814033 Q814995
Q815021 Q817287 Q817606 Q828026


Microsoft Knowledge Base Article - 303013
How to Enable 48-bit Logical Block Addressing Support for ATAPI Disk Drives in Windows XP
http://support.microsoft.com/?ID=303013

Microsoft Knowledge Base Article - 331958
Hard Disk May Become Corrupted When Entering Standby or Hibernation or When Writing a Memory Dump
http://support.microsoft.com/?ID=331958

Windows XP Patch: Hard Disk May Become Corrupted When Entering Standby or Hibernation
http://www.microsoft.com/downloads/details.aspx?FamilyID=b997c...layLang=en

File Name: Q331958_WXP_SP2_x86_ENU.exe
Download Size: 394 KB
Date Published: 1/22/2003
Version: Q331958

This file download contains the following from Microsoft.

Windows XP SP1 Service Pack Hotfix Migration Tool: xpsp1hfm.exe
File version: 5.3.5.0
Created: Wednesday, October 23, 2002, 8:38:40 AM

There is a COMMON folder inside the hotfix with these files
02/27/2002 03:58 PM 4,092 eula.txt
10/23/2002 08:38 AM 18,432 spcustom.dll
10/23/2002 08:37 AM 4,608 spmsg.dll
10/23/2002 08:38 AM 82,944 spuninst.exe
10/23/2002 08:37 AM 404,992 update.exe

There is an SP1 folder with these files
10/29/2002 10:25 AM 87,296 atapi.sys (file version is: 5.1.2600.105)

11/15/2001 03:27 PM 5,149 empty.cat

and folders in SP1 folder
symbols
update


There is an SP2 folder with these files
10/24/2002 03:59 PM 87,040 atapi.sys (file version is: 5.1.2600.1135)
Created: Thursday, October 24, 2002, 3:59:48 PM

There are sub folders sp2\symbols\sys with
atapi.pdb Created: Thursday, October 24, 2002, 3:59:48 PM

There are sub folders sp2\update with
10/29/2002 02:35 PM 7,658 q331958.cat
10/29/2002 12:29 PM 3,787 update.inf
10/29/2002 12:29 PM 85 update.ver

update.ver contains:

[SourceFileInfo]
atapi.sys=F1D915C3870E741D83B5142F3B358761,000500010A28046F,87040


Asif Habib Mar 12, 2004, 05:20am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
Thanks for all the info.

I think there is a more serious problem for users like myself who have the new ASUS P4S800-E Deluxe motherboard and Maxtor Diamond Max 9 (SATA) drives. Other makes of drives seem to have the issues fixed with the tips in this thread but not Maxtor drives. I have a wroking WD SATA drive but the maxtor causes the DWF all the time.

the follwing review highlighted the problem (page 3 I think)
http://www.hothardware.com/hh_files..._p4s800de.shtml

My thread on this issue
http://www.hardwareanalysis.com/content/topic/23233/

Michael Yeang Mar 12, 2004, 11:23am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
To Mithrandir Greybeard:

Thanks for the tip. However, I do not use GoBack or Norton Systemworks 2002, so it's back to the drawing board. Incidentally, I have two 120GB Maxtor hard disks (6Y120P0), one running internally and one running in the external casing through USB. The internal one is a primary slave and does not give me any problem. The external one shows the DWF error only when defragging and when setting properties in folders and files (e.g. compressing the drive or uncompressing it).

Tony Stewart Mar 18, 2004, 06:57pm EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
I found my Maxtor 80GB was constantly doing this at random times 5 to 10 times a week. I later heard over the drone of my system fans the sound of a drive going click and spinning down a minute before the error popped-up on the screen. After researching about this I concluded the drive as too hot and shutting down on its own was not getting reported by XP as a drive unavailable. Any attempts to use explorer on that drive would freeze the OS and would require colld shutdown. I stuck a fan on the drive and re-routed the ribbon cables that were blocking the air flow and the problem stopped except when the fan moved :(. When I got a new tower with 4 drives including the 80gig Maxtor were nice a cool with dual front fans and have rarely stopped but never caused a delayed write now.........Just my observations running 2 different MOBO's on XP Pro

Some drives are better than others. Thermal offtrack is what can cause the heads to mis-position and some number of micro-inches. If the outside of the drive is hot, then the inside is much hotter.

For me the clues were .... It always worked on instant reboot and failed after a while... Drive Seek Rate (power dissipation) is affected by Caching, defragging, or fragmented files and a number of deceptive software factors that increase disk seek activity.. Straight file copying usually did not cause it, but running a Mirror program or multiple D/L's and U/L's from the same drive would increase the probability of delayed write cache.error. Also it started to happen after I added more drives in close proximity with no air gap between and little or no air flow.
The best fix was a new case with front mounted dual fans (and external dust filter) and transverse mounted ribbon cables so laminar air flows over and past the drive with no blocking.

I have stopped blaming Maxtor and Microsoft now about this issue and done what Dell has an HP and that's to keep the drives cool by proper air flow design. I use a Thermaltake Extreme case, which has too many fans but 4 speed controls for optimizing fan noise and air temp.
I doubt Maxtor will tell all their customers to advise their customers on this issue or Seagate for that matter... bad press but I wish XP would at least say Drive offline a little sooner and allow an alternative backup drive to save the critical files for an orderly shutdown, so that recovery would not restore the old hives and old $MFT. But I guess RAID N+1 configs.offer this redundancy for reliability.

Michael Yeang Mar 18, 2004, 09:51pm EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
My external drive, which has a fan in the casing, gives the DWF error even when the casing is opened up and the drive just switched on. So it couldn't be due to overheating in my case. However, it only happens with defrag and changing properties like "compress drive to save space". If heat is the cause, it should also occur when I am copying files, but it doesn't, even after the drive has been on for a while and with the casing closed.

Latest update: I also get the error when defragging through a USB 1.1 hub now. I tried it on another PC running WinXP Pro with an Intel USB chipset on a PCI USB 2.0 card, and the DWF error occurred too while defragging. However, it must have something to do with either the casing or Maxtor 120GB drive as my other external drive (40GB), in a Sarotech Cutie! casing, does not give the DWF error at all.

Corvus Raven Mar 19, 2004, 01:00am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
Wasn't there a posting on USB1.1 and Maxtor Drives seeming to be a problem? (I believe a few pages back)

(perhaps I have just been a way a bit?.. time to sleep.. 7am comes early. :) )

--------------------------
ASUS A7N8X Deluxe PCB 2.00 w/ BIOS 1005 (cause? Dunno.. ATM)
AMD XP 2800+ @ 0.0 GHz 0MHz FSB (overheating for no appearent reason)
(2) - Corsair XMS512-3500C2 (5-2-2-2T) @ 0MHz
ATI Radeon 9700 Pro @0
Enermax 500W p/s (ok.
steve wise Mar 20, 2004, 06:38am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
Ok, I've read all of this, and many links for many hours. Also, on top of that, I've read many stories in the past dealing with this problem. So, in hopes to find the REAL solution, I will add my own experiences.
my specs:
WinXP Pro SP1
Gigabyte GA-7VA mobo (w/VIA KT400 chipset)
AMD Athlon XP 2200+ (1809 Mhz)
768Mb RAM (3x256 DIMMs of PC 2100 DDR266)
ATI Radeon 9200 128Mb AGP8X (128Mb aperture)
Creative Audigy soundcard
WD 60gig HD ATA100 7200rpm (2mb cache) running at setting UDMA5
Lite-On CD-RW 52x32x52

I have never encountered this while working with windows/saving or moving files. Has only happened to me after a restart, and the errors happen at the welcome screen and I can't get back into windows.

I first encountered this problem a while back. I restarted my computer once, and when I got back to the welcome screen, I got the DWF errors of all sorts. (mainly: "Delayed Write Failed: unable to save all the data for file C:\$Mft...yada yada yada) could not get back into windows. I tried to get in through safe mode, and got the same errors. I tried to do recovery, but never set an admin password, and it insisted on having one, so no luck there.


Finally decided to reformat and start over. But here's the weird part. Shortly after reformatting (after installing god knows what programs/drivers and changing settings, and defragging the HD) on one of my restarts I encounter the same problem, on a newly formatted drive/windows install that was maybe an hour old!? I have since tried to find out a little of what caused it for prevention purposes, and the only likely cause in my case was the "Large System Cache" setting because I had purposely changed it a day or two before the first incident. And again after reformatting, and before the second occurance. So I vowed to leave that setting on "Programs" no matter what, assuming it to be the culprit.


Well a couple months go by and all is working well. I must admit to making alot of registry changes for tweaking purposes, but everything seemed to work just fine. Then after playing a video game, i realize my frame rates are too low, and decide to reinstall the 3.7 cats for my Radeon. (instead of the new 4.3 cats I was trying out. I usually try the new ones, but due to missing textures in 3.8 and up. 3.7 always worked the best for my card. I download the Omega version of 3.7 catalyst, and installed it, then restarted. And guess what!? yep, after restart I got the DWF errors again, and can't log in. There is probably a way to get back in, but I can't find it. Instead of total reinstall, I reinstalled windows to the same directory as the old one, and kept all of my files intact. I can now log in and all my programs are still here, but I believe the registry has been reinstalled so the programs are usless, I might as well reformat again. And still have no idea what is causing this, and have to live in perpetual fear that i'll restart and can't log in.


Luckily last time it happened I got the CD-RW, and burned about 30 disks lol. But as you can see, I have no Maxtor drive, no USB HD, no SCSI HD, no raid configuration, HD is not really big, I have only one HD, and I (myself) never enabled LargeSystemCache (this time), unless some program (ATI cats?) edited that registry entry without my knowledge.


Also after turning everything off to let it rest a bit in case of overheating being the cause, the computer started up automatically and ran CHKDSK. It said something about an "orphaned file" "bootex.log", something about another file also, and CHKDSK ran another time automatically shortly after, and fixed a registry entry. (don't have specifics of these cause the info wasn't on the screen long enough to even read it) Also CHKDSK and 2 other HD utilities can find nothing wrong with the HD.


Well, I guess that about sums it up. Maybe with all the info on the net someone can figure this beast out. Until then guess i'm off to reformat for the 3rd time on account of this problem. As of now my best guess is the "SystemCache setting" and this is assuming that ATI cats changes that setting. Also read that Norton's may be changing that setting also, and I got Norton's too. Sigh. Is there a way to lock this registry entry so that it can't be modified, and system cache cannot be enabled?



BTW: I just installed the same Omega drivers, as well as Norton's and that registry entry has not been modified, and Large System Cache is not activated. I'm soo lost on this.

Maluga me Mar 20, 2004, 07:29am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
Hi all
Thought i would post my cure here as it might help some of you gurus
I also had this "delayed write error" yellow box popping up in system tray since i installed a new 80gig samsung back in summer of 2003 after 2 of my h/drives burnt out due to a heatwave we had in the UK.
I`ve never seen this delayed write error before until i installed this new 80gig samsung h/drive.
I`ve looked every where trying to find the cure. I`ve tried many things with no luck :(
I use power quest drive image so i can mess up winxp how much i want and re-install an image file from cd.
But making an image file or installing an image file from disk is now giving me errors.
Even re-installing winxp gave errors on install.
I was close to getting my sledge hammer out from my garage and....
My drive is partitioned into 3 parts C,D,E.
C for windows, D for my game dayofdefeat (online game) and E for all my stuff apps,docs,films,music etc...
The " Delayed write error" would popup when ever it felt like it on all drives and was different every time.
I checked h/drive for bad sectors, none! Changed cables with no luck. Checked for micro updates hoping to find a cure but no luck. Played with lots of different setting posted in this forum and others and still no luck.
Graphic driver updates, no luck!

My setup is P4 1800mhz
Graphic card geforce4 Ti 128meg
Samsung h/drive 80gig SP080N2
1024 sdram
Winxp (fat32) tweaked with no sp1 or sp2 installed

Then i bumped into this site :)

http://www.samsung.com/Products/HardDiskDrive/support/faqs/faq...007938.htm

I d/loaded the files at bottom of page and put the SSUDMA5.EXE on a floppy.
Then rebooted system from WIN-ME floppy into dos (fat32 system).
Then inserted the SSUDMA5.EXE floppy i made and ran the file SSUDMA5.
The write error was so annoying that i was trying anything to cure it!
Anyway.. formatted c-drive only! and re-installed winxp from scratch with all tweaks.
Installation went very well with NO errors:) but i expected the error to pop up any time soon!
Installed all my apps and still NO errors :)
Looking good :))
So far all is well and my babe is running like a dream.
I still have to try out some of my apps like decompressing a 700meg avi which gave me probs before.

Now not all of you have samsung h/drives but maybe it will give you some idea on what to look for if your running out of answers.
Hope it helps some1 as it did me

-=Maluga=-


steve wise Mar 20, 2004, 04:56pm EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
Ok, I got some info. I did a little test and it appears that the fix described at this link http://www.tweakhound.com/xp/xptweaks/atiproblem.htm is what works for me. Before reformatting, I decided to test this theory out. The fix instructs you to change the value of the registry entry "HKey_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SessionManager\MemoryManagement\SystemPages. The value as set (by ATI?) is "183000". The fix suggests changing it's value to "ffffffff". With the value set to "ffffffff" I enabled LargeSystemCache and restarted. No DWF errors upon startup. I then disabled LargeSystemCache and returned the SystemPages reg. entry value back to "183000" and restarted. No DWF errors upon startup there either. I then enabled LargeSystemCache, and left SystemPages value at "183000" and restarted, and BAM! DWF again. I took the time to jot down the error messages and they are as follows, and not exactly in order:

User init.exe - Application Error The application failed to initialize properly (0xc000142).
WINDOWS Delay Write Failed unable to save all the data for file C:\WINDOWS\System32\drivers
WINDOWS Delay Write Failed unable to save all the data for file C:\WINDOWS\System32
WINDOWS Delay Write Failed unable to save all the data for file C:\WINDOWS
WINDOWS Delay Write Failed unable to save all the data for file C:\$Mft
WINDOWS Delay Write Failed unable to save all the data for file C:\$Secure
WINDOWS Delay Write Failed unable to save all the data for file C:\WINDOWS\System32\config
WINDOWS Delay Write Failed unable to save all the data for file C:\Documents and Settings\NetworkService.NT Authority
WINDOWS Delay Write Failed unable to save all the data for file C:\Documents and Settings\"user name"
WINDOWS Delay Write Failed unable to save all the data for file C:\Documents and Settings\LocalSettings
WINDOWS Delay Write Failed unable to save all the data for file C:\SystemVolume Information\_restore {F124F14B-A013-43AD-B7B1-D4C234411580}
WINDOWS Delay Write Failed unable to save all the data for file C:\SystemVolume Information\_restore {F124F14B-A013-43AD-B7B1-D4C234411580}\RP5
Think that pretty much covers the errors lol

Now I went back to Safe mode again and adjusted the registry for "LargeSystemCache" turning it on, and changed the SystemPages registry value to "ffffffff", as per the ATI solution in the aforementioned link, and viola, the system started back up with no errors at all. So, (hopefully) for me, LargeSystemCache can be enabled without DWF errors if the SystemPages registry value is changed to "ffffffff" instead of"183000" Guess i'm off to reformat and reinstall now, and hope that this is truly the cause of my DWF errors, and subsequently hope it's the last I see of them. But this is the first time i've been able to create and undo the problem at will.

NT Doc Mar 20, 2004, 04:56pm EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
Steve and Maluga,

Just curious if you had tried the ATAPI update that I mentioned. Not saying it is a cure all for everyoe, but neither one of you mentioned if you tried it or not.

As far as temp of the drives I'd have to disagree with you. If temp was the issue then all the other OSs should exhibit the same or similar problems.

Not sure what is the real cause, but we have many systems at work with 200GB Maxtor and WD drives in HP/Compaq P4 2.6 systems with 2GB of RAM and none of them are exhibiting this issue. So drive size alone is not the issue, but maybe something in transfer speeds and matching of chipsets.

steve wise Mar 20, 2004, 06:22pm EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
To: Ron Lewis,

Ok, here we go. BTW thanks for the help and the IM. My current HD temperature (according to PalickSoft's CheckHDDTemperature, program.) is 33Celsius. I have also checked this before with a different program and it was around 30C at that time also. As for the cables, I have the rounded IDE cables which do not restrict airflow as much as the flat type. My system temperature ranges from 28C to 32C, so the is not a problem either. But for your (and my) own knowledge and our piece of mind, I updated my Atapi.sys file with the hotfix you linked to. I had the same version number as you did (5.1.2600.1106) to begin with, and the 5.1.2600.1135 version afterward. I restarted and no problems. (this was with LargeSystemCache enabled and SystemPages value set to "ffffffff". But then I changed the SystemPages registry value from "ffffffff" back to the original "183000" And with LargeSystemCache still set to value 1 (LSC on/enabled) and restarted, and BAM DWF errors again. Was tough to even get back into safe mode after, but on the 3rd try I did. I then returned the SystemPages value back to "ffffffff" and restarted, and problem gone again. So while the new Atapi.sys did not hurt, it also didn't help my situation. Now i'm pretty good with computers, but I am fairly new to WinXP (only about 6 mnths experience with xp) And I don't know all the specifics of this, but it appears that to have LargeSystemCache enabled (and mb this is only with ATI cards) you must change that SystemPages value from 183000 to ffffffff. Whatever this does it seems to work. This is the only time I have been able to recreate the problem off and on, and at will. It appears to be the solution, finally.

Also I noticed btw, that the Atapi.sys driver loads in safe mode. So I don't see it as the cause (in my situation anyhow) as with these values set to "1" and "183000" respectively, I can log into safe mode, but not into Windows regularly, yet (if i'm not mistaken) the same (?) Atapi driver is loaded and used in both scenarios.

But I have also noticed different examples of the WDF errors reported and combined all in the same discussions. Some seem to be getting it while in/working with Windows and/or copying a file, and i'm surmising that they can continue working in Windows with no substantial problems. But in my case, and others as well, this never happens while logged into Windows at all, only when starting up after a restart, and the errors pop up at the welcome screen and prevent logging into Windows. So I fear we may be combining different, yet similiar, WDF events and causing some confusion in the process. Anyhow, thanks again, and I wish everyone luck in solving this problem as I feel I finally have.

And again I say: I'm off to reformat, and hopefully play some uninterrupted Battlefield 1942. :)

Michael Yeang Mar 20, 2004, 07:23pm EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
I converted my 120GB USB drive from NTFS back to FAT32 to see whether this problem would go away.

Today, I stumbled upon this Maxtor site,
http://maxtor.custhelp.com/cgi-bin/maxtor.cfg/php/enduser/olh_..._faqid=975

referring to the errors:
Event ID: 50 (Lost Delayed-Write Data)
Event ID: 51 (An error was detected on device \Device\Harddisk1\DR2 during a paging operation).

The comment given in the Maxtor Knowledge Base is:
Event ID 50 and 51 are generic errors that may occur anytime paging information is requested from a drive. Similar Event IDs are 9, 11 and 15. A paging operation is defined as anytime the operating system writes or reads data from memory to drive, or reads from the hard drive and writes to memory. These errors are not caused by the external storage device. The error may be related to problems in either the USB / ATA / SCSI / 1394 controller sub system or another storage device.

Thus, I had the idea of setting the paging file for my USB drive in Control Panel - System - Advanced - Performance Settings - Advanced - Change and set the paging file size to "System managed size" for the USB drive.

When I tried a defrag using Diskeeper, it completed smoothly, without the dreaded DWF error! :) Previously, it would not even do this for more than a couple of minutes. I wonder if the paging file set on the drive had something to do with it? Since I've tried this only once after setting the paging file and got success, I'm reporting this in case someone else would like to give this a shot too. This does not mean that the next time I defrag, it would work properly. I've experienced too many "too-good-to-be-true" things in the hi-tech world.

Now the only problem I have is that the system hangs at the post if I start it up with the USB drive on. If I switch on the drive immediately after the post has passed, it boots OK. This doesn't happen with my other 40GB USB drive, though. Any explanation for this, guys? Maybe I should enter this as a new thread.

Chun Heng Phuah Mar 21, 2004, 08:31am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
I have a WD2500JB 250GB HDD connected to my notebook, Dell Inspiron 8200 via USB 2.0 all these while and it has been working fine till today, even for files larger than 300MB. Today, when I try to copy a file which size is around 700MB... I started getting "Delayed Write Failure" error during the transfer process. Since then all files larger than 300MB can no longer be copied from my laptop to my external harddisk!

MICROSOFT! YOU BETTER FIX THIS UP!

Chun Heng Phuah Mar 21, 2004, 11:19am EST Report Abuse
>> Re: "delayed Write failure" in WIN XP
Maybe I should post more info on the problem that I encounter:

- I already installed the latest ATAPI.SYS file from microsoft.
- Everything has been working fine all these while till today. The major difference between other times when I used to copy large movie files is that the space left on my notebook's HDD this time is rather low, about 3GB. Normally my notebook has 8GB of free space.
- Tested on USB 1.1 via my notebook and USB 2.0 via PCMCIA card to my notebook. The DWF error still presist.
- Using Windows Home SP1 with all the latest patches applied.
- Problem only occurs when I copy files larger than 300MB to my external HDD.

Specs of my notebook:

Dell Inspiron 8200
2.0GHz P4-M Processor
Dell's Ultra Sharp UXGA 15.1" LCD Screen
512MB PC2100 DDR SDRAM
40GB Hitachi DK23EB-40 5400rpm HDD
250GB Western Digital WD2500JB 7200rpm USB2.0 External HDD
32MB GeForce4 440 Go Graphic Card
HLDS (LG) GCC-4240N (24X/8X/8X/24X) Combo Drive

PS: I guess we should send the address of all the threads here to microsoft and show them there is a HUGE BUG in their "STABLE" Win XP!

I'm so fustrated! Now I have so much to copy from my notebook and all my files are stucked! Someone please help...


Continue Reading on Page: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, Next >>

 

    
 
 

  Topic Tools 
 
RSS UpdatesRSS Updates
 

  Related Articles 
 
 

  Newsletter 
 
A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.