Please register or login. There are 0 registered and 903 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s July 03 - 04:36am EDT 
Hardware Analysis
      
Forums Product Prices
  Contents 
 
 

  Latest Topics 
 

More >>
 

    
 
 

  You Are Here: 
 
/ Forums / Other Hardware /
 

  "delayed Write failure" in WIN XP 
 
 Author 
 Date Written 
 Tools 
Continue Reading on Page: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, Next >>
Jorge Kaplan Jul 29, 2004, 11:34am EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
Windows-Delayed Write Failed is a protection against piracy and terrorism
from MS and goverment
You don't find solution in formal sites

Want to enjoy less advertisements and more features? Click here to become a Hardware Analysis registered user.
Corvus Raven Jul 29, 2004, 11:17pm EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
Then explain why it happens after or during a freash install, or durinafter transfer of a file you created?

oops..

--------------------------
ASUS A7N8X Deluxe PCB 2.00 w/ BIOS 1005 (cause? Dunno.. ATM)
AMD XP 2800+ @ 0.0 GHz 0MHz FSB (overheating for no appearent reason)
(2) - Corsair XMS512-3500C2 (5-2-2-2T) @ 0MHz
ATI Radeon 9700 Pro @0
Enermax 500W p/s (ok.
Chris Gehlke Jul 30, 2004, 01:08am EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
I got the DWF a month ago when my 160GB IDE maxtor was in a 51/4 drive hot swap. upon entering the directory got DWF a bunch of times, so i thougth the drive was trash and immediatly copied over to another 40 gig i had laying around. got the DWF a bunch of times then, then i figured maybe the Hot swap wasn't ata 133 compatible evne though in the bios it was marked ata 133, so i put the drive in the lower hard drive holder in the case and hooked it up, bingo! no more DWF, I formatted partitioned and copied the data back no problems, maybe it has something to do with using hot swap drive bays. But i cannot be for certain. let me know if anyone else has had this problem with using hot swap drive bays

Corvus Raven Jul 30, 2004, 02:00am EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
I didn't recive any.. (so far) with my 120G hot swapable bays..

--------------------------
ASUS A7N8X Deluxe PCB 2.00 w/ BIOS 1005 (cause? Dunno.. ATM)
AMD XP 2800+ @ 0.0 GHz 0MHz FSB (overheating for no appearent reason)
(2) - Corsair XMS512-3500C2 (5-2-2-2T) @ 0MHz
ATI Radeon 9700 Pro @0
Enermax 500W p/s (ok.
M H Aug 01, 2004, 12:42pm EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
I started getting this error a few days ago after plugging my Western Digital USB 2.0 external hard drive back in my laptop, via the usb2.0 pcmcia hub, and tried to download a mouse driver to it. The drive registered as busy for the longest time, and then I got the DWF. Not thinking anything of it, I saved the driver somewhere else, installed it, and rebooted. Upon reboot, I tried to open the drive in windows explorer and was asked by windows if I wanted to format it. I panicked, of course, but as I later figured out, my data wasn't gone, just whatever lets an OS read the drive was somehow deleted. I bought a data recovery program and got all my data, then set to trying to fix the problem.

Last night, I installed Linux (Simply Mepis, RC2) to dual boot with windows, and used QTParted to format the usb drive as one giant fat32 partition, and was able to copy things to it in Linux. Thinking the problem was fixed, I booted back into Windows and tried to copy some more things over. Again, the drive registered as busy for several minutes (transferring a 60kb picture) and then I got the DWF message again. Again, Windows wasn't able to read it anymore, and so I booted back into Linux. It didn't show up as a fat32 drive anymore, just as "unknown file system" so somehow this error for me deletes the partition information table or whatever tht's called. I again reformatted it as a fat32 drive and tried again in Windows. No luck, repeated the boot into Linux and format.

I tried plugging it into my laptop's usb1.1 ports, and it worked in both Linux and Windows, no DWF no matter how big the file. That's not really very useful for a storage drive though, as it took me about 8 minutes to transfer one linux ISO. So, thinking about the fact that the drive worked plugged into the usb2.0 pc card hub in linux, but not in windows, i realized something was amiss with the windows driver for it. The manufacturer (Belkin) does provide drivers on CD, but as it happens, when i installed windows, windows put its own drivers in instead of using Belkin's (it was listed as NEC pci to usb controller). I clicked update driver in device manager and forced it to use Belkin's drivers. Problem solved. I have copied mass amounts of data back onto my now clean external drive with no DWF.

It seems this error has many causes, but perhaps someone else in a similar situation will find this post handy.

Corvus Raven Aug 03, 2004, 12:36pm EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
..windows put its own drivers in instead..


I've had this problem with a few things. Windows wants total control. Conspiracy.. That's what it is. :)

--------------------------
ASUS A7N8X Deluxe PCB 2.00 w/ BIOS 1005 (cause? Dunno.. ATM)
AMD XP 2800+ @ 0.0 GHz 0MHz FSB (overheating for no appearent reason)
(2) - Corsair XMS512-3500C2 (5-2-2-2T) @ 0MHz
ATI Radeon 9700 Pro @0
Enermax 500W p/s (ok.
Jamie W Aug 05, 2004, 05:17am EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
i am getting this delayed write error out of no where.

I have been, for almost 6 months flawless error free playing. Till one day i decided i wanted to upgrade my comp. And before my parts i was gonna format. So then i formated. Big mistake. I can install run windows fine. I can install and play anything just fine. But the second i install any radeon drivers i get a delayed write error on next reboot. Not just from the &mft, but also fom my documents, network places, and many more. I tried every cure i can find, i diabled write caching, i made sure i was on Programs and no System Cache, my bios dont have a Force UMSD(or whatever) feature so i coudln't disable or enable it. I used the regedit fix (didn't work for me) and the smartguard wont come up unless i reset after installing the control panel so i cant use that. Its funny its just now happening afte flawless playing and just decidin to format. I am using 40 pin 80 wire cabels. Like i said i tried just about everything. I even went out and bought new HD to see if that was the problem. nope. Even on a brand new HD i get same error. Only happens when i install any ati driver. Only time it does work is when i hook up the card, but dont install any drivers. Can anyone please tell me wtf the problem is. I really wanna get back to gamming but without this crap working i cant do nothing. Ive sepnt 7 hours of reformating and installing windows over and over trying all these fixes, an franklin none are working for me.

using
AD72-SC/Sn System Board
VT8233 Chipset
ATI Radeon 9200
40 GB Segate HD
384 Ram
AMD Athlon 1200.

Can someone please help me.

Artemus Manore Sep 01, 2004, 06:43pm EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
I've been recieving this same problem after installing a new Maxtor 250GB PATA 133 and a Syba 133/RAID card. I used the existing rounded cables (2 device 18 inch cable supposedly 133 compatible) in my system and got the "delayed write failure" upon starting windows. After reading that it might be the cable, I switched the cable with the ribbon that came with the drive... and the problem went away completely (no warnings or errors in the system Event Viewer). I then bought a 24 inch Vantec ata 133 rounded cable and got the same problem with the "delayed write failure". In fact I returned the cable for another of the same brand and type and still the same issue. I am convinced for my system the issue is the cable. I'm concerned though because I would definitely like to use a rounded cable (seeing that ribbon through the side window is just sad), but I've gone through one 18 inch cable and two 24 inch cables with no luck. Has anyone had this kind of issue with cables before?

Tony Stewart Sep 02, 2004, 07:18am EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
My recommendation is try a different connector combination for source and destination or better yet use the Flat Cable and fold it half and tape it for a low profile neat connection like origami. and use 45 degree folds on corners and tape if necessary. Signal degradation is minimal and this is what I do. It also allow better air flow over the drives in my case.

I think Delayed write is a lack of detecting the response to a Write Command. Since the drive is OK, either the Drive never read the command or the MOBO never read the response, but the former is more likely as the latter would be a stream of responses. ALso cached Disk operations means the drive action is not immediate and so the OS doesn't have to wait. BUt if after the timeout, other disk actions seem to work OK and the former Disk Write Operation Timed Out then I would suspect signal reflections on the 133 MHz IDE bus. It is not a proper controlled impedance and terminated bus like SCSI so it is more prone to errors.

I believe this is often why most people recommend using the end connector of the Cable for the Master, due to cable affects on signal with reflections and lag time. THe flat cable has much less cross-talk than a round twisted pair, so I woulkd expect better performance. The 80 wire IDE cables have interleaved grounds in the 40 pin connector to suppress adjacent signal cross-talk and provide a more controlled impedance to fast rising signals. (but not as good as Coax)


Toby McClellan Sep 03, 2004, 10:13pm EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
All right, so I had the DWF error on a Nexstar 350UF with a Prolific PL3507 chipset <rev A or B is unknown> with a firmware date of 7/27/2004. I tried flashing it but as the firmware posted on the net is older than the firmware in the chipset, the flash failed. Now I found this site http://member.newsguy.com/~siccos/ with a packet fix. IE it adjusts the length of the packets sent to the device. My drive now works, but not with firewire :/ However, since I have USB 2.0 <on which it also wasn't working> I tried that connection and low and behold! I moved 5.08GB onto the drive with no failures, which I couldn't do before. Now, according to this site http://www.bustrace.com/products/delayedwrite.htm they've had the same issue and have had various success with firmware changes etc. Right now, honestly, all I care about is my external drive now works reliably on USB 2.0 <I'd like to have it work on firewire for the dedicated bus but eh, beggers can't be choosers>. So, hope this helps out. Good luck all.

Nick Lytton Sep 22, 2004, 05:26pm EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
Have I cured it on my system?

I have a fairly "busy" system with 3 internal hard drives and one external firewire drive. I started to get DWF errors when I replaced one of the internal 120Gig Seagate drives with a Maxtor 200Gig drive. Actually no data was lost in most cases but the error would keep coming up repeatedly (often even if I wasn't actually writing data to the drive such as M:\$Mft) for about 10 minutes after a reboot. After this 10 minutes the DWF errors would usually stop appearing. It was always on 2 of the 3 extended logical partitions on the 200gig Maxtor drive. The PC has never seen an ATI card.

The suspision was that I would start losing data though and when one of the partitions finally became unreadable, I was getting really worried. Re-formatting the drive showed there was nothing physically wrong with it and no errors were shown with CHKDSK. After every update, registry mod, large drive enabler etc, buffer size/speed twek, still no change. Finally I put a system controlled swap file on the Primary partition of the offending drives and also one of the logical partitions. So far, for a couple of days I have had no DWF errors at all and the machine is as fast as it ever was!

My set up is as follows;

P4S8X Mobo,
2.4Mhz P4
1 gig Ram
Windows XP Pro with SP1 & 2 and all latest updates.
Nvidia GeForce4 MX440 (128meg)
Pioneer DVD RW DVR-105
Pioneer DVD Rom DVR-106
Main disk - Maxtor 6Y12OLO partitioned into 5 drives
Second disk on a an Sil0680 card - Maxtor 6Y200P0 (the main offener) partitioned into 4
Third disk on a Sil 3112 SATA card - ST3160023AS partitoned into 2
Fourth disk in a combo external USB/1394 case - Seagate Baracuda 7200 120gig partitioned into 2
Internal IDE Zip 250meg drive
Lots of USB devices

Did I say it was a "busy" system?

Nick

JESUS DIAZ Sep 23, 2004, 10:49pm EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
i have narrowed this problem down to any pc with ati brand 4x and 8x video cards
you remove the card and replace with a different brand and a fresh install of xp
and the problem dissapears
reinstall the ati
and guess what
delayed write fail again

i am a microsoft oem system builder
i do this for a living
i have all the certs needed
and i have been doing this since 1989

all that and $1.25 with buy me a coffee at the dinner across the street
but it wont solve my problem and neither can i

ati blaims microsoft
microsoft blaims hardware manuf (motherboard)
manuf (motherboard) blaims ati
and they all blame me

but when i put in a g-force the problem goes away

so i dont know which wrist to cut first my left or my right

and of couse all my customers insist on ati cards

any help from any one ( even the tooth fairy ) would be appreciated

thank you in an advance

zuester

Robzzz Sep 24, 2004, 02:00pm EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
Gee I had this problem way back in the beginning when this thread first started. I was convinced then that the problem was caused by the ATI drivers, or because of how the drivers were installed. In the end I went with a G-Force card and never had the problem. Lately though I bought an ATI X800 graphics card and I haven't had any problems-touch wood since I installed the card and drivers. Even the ATI card that I had the problems with origonally, I now have in a second machine, installed with the latest drivers, and have not had any kind of issue.


Robzzzz

Tyson Gill Oct 02, 2004, 10:16pm EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
YEA! Fixed this.

Running XP with all latest patches. My Maxtor One Touch 250GB kept getting this error copying large files. Tried all the fixes including registry changes I could find on the web, with no luck.

Then I noticed the suggestion that ATI was involved. I have an ATI 9700 Pro, and I had noticed that it shared an IRQ with USB. Seemed suspicious. So I checked ATI and found they did have a recent driver update.

Installed the ATI driver update, and now my USB drive works like a champ!

Tyson Gill Oct 02, 2004, 10:27pm EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
Errgh, scratch that. The ATI update definitely helped, cause got the error almost immediately before. But now got the error about 1/2 hour into copying a ton of mp3 files. Sorry...

afirstname alastname Oct 11, 2004, 11:56pm EDT Report Abuse
>> EMERGENCY: How to recover such a drive?
Well, the Delayed Write Failure just hit me, and now 200gb of my 250gb NTFS hard drive is missing. AHHHHHHHHHHHHHHHHHHHHHHH............

I read a few posts in this thread where people said they recovered their data. PLEASE send me a tip about this. I know the data is there, and I need it. I'm not touching this drive until I can figure out a recovery solution. I'm very tech savvy, but I'm not familiar enough with the recovery options with an NTFS drive.

Thanks. I'm trying not to get suicidal.

Michael Yeang Oct 12, 2004, 12:36am EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
You seem to be in dire straits, so I was empathetically prompted to offer my 2 cents. Try booting up in safe mode and see if your data is there. The minimum of drivers are loaded in safe mode so that whatever was contributing to the error hopefully is not there, if it is related to a driver.

Is yours an internal drive? If so, you may have to remove it and connect it as a slave to another computer that does not have the DWF error to see whether the missing data is readable. If you don't have another computer, then try a friend's. If the data is really not there, you may need to use a data recovery software. Some good ones have been suggested at this forum: http://www.experts-exchange.com/Storage/Q_20632426.html.

If it is an external USB drive, connect it to another computer to check your data. Occasionally, I get this with my external drive and then I would have to switch it off and on again.

Have you tried the solutions on page 7 of this forum? By the way, what make is your hard drive - Maxtor?

afirstname alastname Oct 12, 2004, 03:44am EDT Report Abuse
>> Data recovery attempt
The drive is a second drive, so my machine boots fine. It's an external drive, a WD 250gb in a Bytecc (a.k.a. the maker of many "generic" enclosures) crappy USB 2/Firewire a (Oxford 911 for the Firewire bridge) enclosure, formatted as NTFS. Delayed Write Failure happened while connected via Firewire and sending a lot of data.

(What's especially crappy about the enclosure is that the power switch is badly designed, and became defective after a few months. It took ages to determine that the drive spin down problems I was having were actually due to a weak contact on the power switch which wasn't letting enough power through!)

All folders are gone except one (which has 650mb of data in it).

Right now, GetDataBack is having a go at it. (I'm connecting via USB.) It'll still take a few more hours before I find out how good its results are.

I would love to know what happened, and why it resulted in removing most of my root directory entries. And I am curious if any other data was overwritten. I suspect the data recovery process is going to be very arduous, but at least with this tool it seems possible (so far).

You wrote: "http://www.experts-exchange.com/Storage/Q_20632426.html"

Nice link!

You wrote: "Have you tried the solutions on page 7 of this forum?"

Well, those are all about trying to eliminate the Delayed Write Failure problem. Right now I'm focused on trying to get my data back...which includes that I have to buy a new drive just to recover this drive onto! That is, assuming GetDataBack actually finds anything.

Thanks for your reply! I'm going to freak out if my data is not recoverable.

Michael Yeang Oct 12, 2004, 04:28am EDT Report Abuse
>> Re: "delayed Write failure" in WIN XP
Let me know if it works.

The first thing you should do if you can get your data back is to make backups, perhaps on CDs or DVDs, so that next time you do not have to resort to using a data restore software. There's always some doubt whether all the data can be restored exactly the same as they were before.

I use an external 120GB disk for backing up my data, as well as DVD-RWs. If your data is truly lost, all the money in the world cannot get them back and it's especially frustrating if they are important.

afirstname alastname Oct 12, 2004, 06:16pm EDT Report Abuse
>> Recovery not going so well
Disturbingly, the tool can recover everything EXCEPT many of the large files, which are exactly the ones I really need. In this process I am learning much about NTFS.

I would like to better understand the Transaction Log. I have read countless articles about it, and I can read the thing with my hex editor. My question is, in this situation, will it be used? Or is this corruption already "committed"? Because the Transaction Log does appear to list the last things that were done to my drive. I have no way of telling with a hex editor whether they've actually been committed or what.

The great mystery of my data failure is that I have MFT entries for the files in question, but their "run" sections are empty, i.e. they don't list any allocated clusters. Since this is only for very very large files, I'm thinking that the MFT entry is supposed to continue in a non-resident entry, which will go ahead and provide the lengthy list of used clusters, but somehow these non-resident entries were lost.

Meanwhile, I have to wonder if a simple "chkdsk" would repair the problem. But it could just as easily destroy what chances I have to salvage some of my data.

So I'll need to buy another drive and ghost the entire thing over, just so I can be in a position where it's safe to try running chkdsk.

This whole process is a bit of a nightmare. Backups would have been great. Sadly, I didn't have a second 250gb drive to backup to. Backing up gets difficult and/or costly when you're dealing with this much data. Of course, as you said, nothing is worse than losing unrecoverable data.


Continue Reading on Page: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, Next >>

 

    
 
 

  Topic Tools 
 
RSS UpdatesRSS Updates
 

  Related Articles 
 
 

  Newsletter 
 
A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.