Please register or login. There are 0 registered and 1130 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s August 09 - 08:53am EDT 
Hardware Analysis
      
Forums Product Prices
  Contents 
 
 

  Latest Topics 
 

More >>
 

    
 
 

  You Are Here: 
 
/ Forums / Portable Hardware /
 

  Vaio PCR-GRX560 New Problem?? 
 
 Author 
 Date Written 
 Tools 
Jim Stiles Jan 07, 2005, 08:17pm EST Report Abuse
A couple of weeks ago my 560 LCD went blank but with the desktop items showing using a light shinning on the screen. I replaced the backlight and inverter board today, now the screen lights up but nothing is showing on the screen, I can connect to crt and the computer works fine. Could I have forgotten to hook something up or crossed something when putting it back together? Any Ideas?? Thanks


Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
Ken LaDere Jan 07, 2005, 08:58pm EST Report Abuse
>> Re: Vaio PCR-GRX560 New Problem??
Hi Jim.. Is this a 16"? If so there is one thing to consider doing the backlight in these.. ( They are a pain in the rear).. Its lighting thats good, that means the backlight and inverter circuit is doing what it is supposed to.(you did good here). Check the DIP switch and see what theyre set at.. (These are easily misaligned if you inadvertantly bumped removing the Vid chip fan or similar).. Although these will usually throw your video its still working somewhat. The 16" Vaios have a surface mnt cap in the layers thats easily torn from a thin trace and you have to be careful this doesnt happen as well. This can be a total problem but it can also be rectified it just takes time and patience.(requires redoing the circuit). Recheck your video to Motherboard cable.. Never pull one out by the wires. This dislodges and will partially pull the coupling leads from the socket slightly as well.. (Help it out from the edges with a flat bladed screwdriver)(Lines.. Blotched/garbed vid.. No video out).. Recheck and yell back.. I like it here.. this is the BEST place on the web to meet people and get help) Last but not least?? If its a 15 " Check that the cable didnt come disconnected from the LCD on reassembly...I have done this before and felt totally stupfounded as to why it didnt fire up... Good luck and yell if you need help!

Ken LaDere
http://www.ikenfixit.com
231.539.8779
231.758.0529 (message)
ken@ikenfixit.com
Jim Stiles Jan 07, 2005, 09:18pm EST Report Abuse
>> Re: Vaio PCR-GRX560 New Problem??
Thanks Ken,

It is a 16", sorry forgot to mention that part. It seems to fire up good, startup music and everything, just nothing but a lighted screen. I have some real slight shaded areas across the bottom of the screen but I can probably live with that, they aren't too bad, I probably bent the reflector or something. I'll recheck the plug you mentioned to make sure I didn't pull a wire loose, I tried to be careful with it but I've been in that darn thing 4 times today so there's no telling. There was a "thin" cable type of connector is saw in one of the corners of the screen while I had it all apart and I'm pretty sure I got it back where it belongs, that was tricky. Other than that, there just isn't much I can see that I might have messed up unless it's one of these wires you mentioned or a grounding problem or something.

Thanks again, I'll check and let you know what I find.

Jim

Jim Stiles Jan 08, 2005, 08:47am EST Report Abuse
>> Re: Vaio PCR-GRX560 New Problem??
Ken, I've checked the plug and it looks like all the wires are still in place as far as I can tell. I was careful not to pull it loose using the wires but I have no way of telling for sure that is the problem. Is this wiring harness replaceable and if so, what is it called so I can try to find one just in case. Also, can you describe the where the dip switch is and what it looks like, I can't seem to find it although from your answer, that probably isn't the problem as the screen does light up good.

Thanks
Jim

Jim Stiles Jan 08, 2005, 10:32pm EST Report Abuse
>> Re: Vaio PCR-GRX560 New Problem??
Does anyone know of a site where I might be able to locate a schematic of the Sony Vaio PCG=GRX560 specifically of the wiring harness from the motherboard to the LCD?

Thanks,
Jim

Jim Stiles Jan 11, 2005, 06:33pm EST Report Abuse
>> Re: Vaio PCR-GRX560 New Problem??
Well, I decided to order a new LCD harness to see if that might be my problem. I found some by searching google by part number for anywhere from $60 to $80 but I found one on eBay for $35 including shipping that was rated as grade A so I'm going to try that one and see what happens. Will post the results when it comes in.

lisa pasquale Jan 15, 2005, 11:59am EST Report Abuse
>> Re: Vaio PCR-GRX560 New Problem??
hey, I'm having MAJOR problems with my Vaio GRX560. It's freezing 2-3 times a day. IT IS NOT A SOFTWARE/OS problem. It often won't reboot after it freezes. When I power up the computer, the hard disk with spin a little and the fan will turn on, then it won't go any further. When this happens, the LCD won't power up and the hard drive will stop spinning. when the computer is on and freezes, it's often happening when I shift my wieght under the laptop or physically move it. I have a feeling that this is an issue with the motherboard... perhaps a racked solder connection? Has anyone had similar experiences with this sort of thing? if i try replacing the motherboard, what kind do i need? PLEEEEASE HELP ME!

Matt D. Jan 19, 2005, 06:20pm EST Report Abuse
>> Re: Vaio PCR-GRX560 New Problem??
Lisa,

Sounds like the common memory slot issue where the solder joints have broken loose. Looking at other forums, esp. my sony vaio won't boot, you can read more than you would ever care to know about it by countless others experiencing the same issue. There are four or five folks I see here regularly who can fix it for you for a fraction of the cost of a new board. I have done a few, just don't have a web site yet, ken does them http://www.ikenfixit.com, joe does them http://www.aqstech.com, and I think there are one or two more. Let me know if I can help any more.

Charles C. Aug 17, 2005, 12:40am EDT Report Abuse
>> Re: Vaio PCR-GRX560 New Problem??
I am so upset and about to throw my GRX560 away. Here are all the problem I have now:

1) I had my laptop connected to power without using the battery for a while. One night lights went out from my home area and then when power came back I found my computer starts fine but no display ( works fine with my desktop's monitor ). What could be the problem, inverter or backlight. If it's backlight problem, how many bulbs does it need?

2) I put this laptop for more than one year. Until recently I turned it back on and found my computer has only 256MB / 1.19GHz instead of 512MB / 1.6GHz. After doing some research from this site I found out about the common problem for memory and got it fixed by placing folded paper between the memory cover. Got my 512MB back, but still 1.19GHz only... Can someone help me on this one?

Thanx all



 

    
 
 

  Topic Tools 
 
RSS UpdatesRSS Updates
 

  Related Articles 
 
 

  Newsletter 
 
A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.