Please register or login. There are 0 registered and 806 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s September 24 - 08:57am EDT 
Hardware Analysis
Forums Product Prices

  Latest Topics 

More >>


  You Are Here: 
/ Forums / Cooling and Airflow /

  SpeedFan not working for me... 
 Date Written 
ahmad najeeb Jan 23, 2008, 04:17am EST Report Abuse
hi guys....well I am trying to change the speeds of my new A. C. Ryan Blackfire fans using SpeedFan 4.33 under Windows XP, but nothing is happening for me :(...

I tried checking and unchecking the 'Automatic Fan Speed Control' thing, but that didnt work for me either...

From what I can guess, to change the speed of a fan, I only need to increase or decrease its percentage, and the change should be effective immediately (that is, i do not need to press any 'Apply' or 'OK' button to confirm the change)....

Also, SpeedFan seems to be detecting my board fine (Nforce 4, for DFI nF4 LanParty SLI-DR)...

The temperatures are being detected too...

For some fans, the RPM is showing as well in SpeedFan, but when i try to modify the speed, nothing happens...

Lastly, I also tried the latest motherboard configuration uploaded to their website for my motherboard, and using that, but this didnt work too....

What could I be doing wrong ?

Also, is there any other fan speed controlling program out there ? Whenever I google 'fan speed control', all I get is SpeedFan :P

thanx in advance...

SOLD !! $1637.62.........v5.0:
AMD Opteron 165
eVGA Geforce 7900GT CO
OCZ PowerStream 520W
LITE-ON LightScribe Burner
AeroCool AeroEngineII
ViewSonic 19" Wide LCD
Logitech X-530 70W 5.1
Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
micro Jan 23, 2008, 01:08pm EST Report Abuse
>> Re: SpeedFan not working for me...
On my and my friends nforce 4 mobo, the only fan that speedfan will control is the cpu fan. To get the chipset fan to change, you have to run "cool and quiet" from the bios, if your mobo comes with it.Evan after i dl the mobo configuration.

And speedfan is about the only one out there from what i have seen. Riva tuner will control the video cards fan though.

A hardware fan speed controler would fix the problem. Antec sells fans with a speed control switch on them and antec also sells psu's with a fan speed controler in them to control the case fan speeds.

GA-Z68X-UD3H-B3, 2600k @ 4.0
16 gig Corsair Vengeance
Evga gtx 260 216, samsung 2253lw"
Baracuda 7,200.12 CoolerMaster 212 +
Win 7 64, fsp fx700-gln, Razer DA,G15
Evil is powerless if the good are unafraid
Silence in the face of evil is it's self Ev
john albrich Jan 23, 2008, 08:11pm EST Report Abuse
>> Re: SpeedFan not working for me...
As micro pointed out, sometimes you have to 'play' with BIOS/CMOS settings to enable fan control. For example, if you have the computer set to over-ride speedfan thresholds, then speedfan will appear to not be doing anything.

You are right that the speed changes should be observable within a second or so after you change the percentages in the main panel.

Also, go to the "speeds" tab and check your settings for the fans.

You may have more luck dealing with a specific mobo's idiosyncracies over at the speedfan forums.

Matt Muir Jan 31, 2008, 09:54am EST Report Abuse
>> Re: SpeedFan not working for me...
sorry to hijack this thread but I thought it would be an ideal place to start...

I'm havin the same problem with my speedfan i.e. I cannot adjust the cpu fan speed.

The reason I've been trying is because my arctic cooling freezer 64 pro cpu cooler seems to be stuck at about 2300rpm when the system is idling and will not drop down at all! Obviously my CPU is running quite hapilly and very cool (somwhere between 30c and 40c) but what used to be an almost silent fan is now running rather noisily.

Has anyone any ideas why my fan won't slow down?

I'm running an athlon 64 3000+ processor on an ECS nforce4-a939 motherboard. The cool 'n' quiet setting is enabled in the bios and according to the amd dashboard utility (and windows system information) my processor is stepping down to around half it's clock speed when idling.

john albrich Jan 31, 2008, 10:54am EST Report Abuse
>> Re: SpeedFan not working for me...
Matt Muir said:
sorry to hijack this thread but I thought it would be an ideal place to start...

I'm havin the same problem with my speedfan i.e. I cannot adjust the cpu fan speed....

This may not be a Speedfan issue at all, and you may want to open another thread.

A few questions/thoughts:

What do your BIOS fan control settings show?
Try removing Speedfan from startup and control the fans by BIOS settings only.

Do you hear the fan change pitch during POST? If not, then your fan driver circuitry may be shorted out in the 100% on state. In many motherboards, the CPU fan speed is changed and tested that it changes during POST. You can usually hear the very obvious change in pitch. It's also possible the CPU fan-speed control subsystem is damaged or not being properly initialized during POST.

Example: the CPU fan speed control on one motherboard I have supports a MAXIMUM of 600mA...some CPU fans take a LOT more current than that and can damage the mobo's standard CPU fan controller.

Can you test the fan itself with another fan control sub-system? It's possible the fan's speed sensor isn't functioning properly, or as I mentioned above the CPU fan speed control sub-system has a problem.

Matt Muir Jan 31, 2008, 11:45am EST Report Abuse
>> Re: SpeedFan not working for me...
in bios the fan speed is reading the same (i.e. around 2300 rpm - above the maximum stated for the fan). I do not normally have speedfan running. only loaded it up to check what speed the fan was running at because I thought it seemed louder than it used to be.

MY thoughts were that there is a fault with the fan too. I can't detect any change in pitch of the fan during post either.

Unfortunately I won't be able to get a spare fan to test for a few weeks as all my spares are currently at my parent's house so it looks like I'll just have to make do with a noisy fan until then :(

john albrich Jan 31, 2008, 12:26pm EST Report Abuse
>> Re: SpeedFan not working for me...
You may not have to wait.

You may be able to tell if it's the fan or the fan speed control sub-system on the motherboard that's at fault if you have a 3-wire variable speed system fan installed in the computer.

This also assumes your system POST does in fact cycle the CPU fan thru several speeds ranging from low to high as previously noted some systems do.

You should do all this with your disk drives disconnected.

You should be able to plug the 3-wire system fan into the 3-wire CPU fan's controller plug. Make sure the CPU fan's speed controller's maximum current limit isn't exceeded by the system fan (unlikely)

Power-up the computer and this time listen for the system fan speed to vary during POST. Then power-off the system so the CPU can't begin to overheat. (or, you can plug the CPU fan into the system fan's connector...again make SURE it won't overload the system fan's speed control circuit...but doing so may make it more difficult to audibly detect any system fan speed variation as it is usually quieter than the CPU fan)

If you don't hear the system fan speed varying during POST while it is plugged into the CPU fan speed control circuit (and still assuming it is supposed to do so) then it is most likely that the speed control circuitry on the motherboard is either damaged or not being properly initialized by BIOS.

Matt Muir Jan 31, 2008, 12:31pm EST Report Abuse
>> Re: SpeedFan not working for me...
ok, thanks for that suggestion -I've got a new psu on order too (my 550w is a little overrkill for my system!) so I'll be fitting that when it arrives sometime next week. I'll have a play with the fans while I've got the machine in pieces ;)

Thanks again,


john albrich Jan 31, 2008, 11:53pm EST Report Abuse
>> Re: SpeedFan not working for me...
Because of your thread, I decided to investigate the CPU fan on one of the simpler systems I own.

I thought the CPU fan was running at its maximum RPM all the time, because it too, cannot change speed under user control.

However, I found out the CPU fan is in fact, NOT running at its maximum RPMs.

I have an 8VM series GigaByte motherboard, and it does the following normal things for that mobo:

1) BIOS says the CPU fan operates at ~2570-2600rpm
2) Does NOT vary/test the CPU fan speed during POST
3) Speedfan reports the same RPMs accurately, but CANNOT change the speed

There is NO mechanism for controlling the fan speed in CMOS only reports the speed. It has a Fan failed "0rpm" detection option, which made it seem that the only reason it monitored the speed of the fan was to detect if it stopped spinning completely. The fan speed detected really must drop to 0 for the alarm to activate...a "fatally" slow fan will not activate this alarm.

While both BIOS/CMOS and Speedfan report the CPU fan speed is at a near constant ~2600rpm, it is NOT running at maximum speed during or after POST.

The CPU fan's maximum speed (achieved by supplying a straight un-modulated 12VDC to the fan) is approximately 3800rpm (determined by photo-tachometer)

So, like this GigaByte board, you may simply have a mobo that does not adjust the fan speed under normal conditions, and either keeps it running at a below-maximum value, and/or only speeds it up when the CPU temperature exceeds a much higher value*...which probably differs for each motherboard.

*edit to add--Being unable to get rid of the curiosity bug, I did a little more testing. I manually elevated the CPU temperature, and when it hit about 45C, the fan speed finally started to automatically increase. I got it to go up to ~3300rpm. On this system it is very difficult to get the CPU to heat up very much (a simple combination of low-CPU-speed and good heat-sink?) I had to add a hair dryer into the mix to raise the temp more than 5C. It normally runs within 5C of room temperature (at the base 2600rpm fan speed) no matter what program(s) I'm running.

peeee jayyyyy Feb 02, 2008, 11:59pm EST Report Abuse
>> Re: SpeedFan not working for me...
here's food for thought on your problem...
last october i started using speedfan on drive c so i could use my boiling laptop..
i created drive d and put it there too... no detection in the speed tab of anything... no little box with up / down arrows on the readings tab page to adjust fan speed... why is it so ? same machine... different drives

john albrich Feb 03, 2008, 02:32am EST Report Abuse
>> Re: SpeedFan not working for me...
peeee jayyyyy said
...i created drive d and put it there too... no detection in the speed tab of anything

If you're saying you created another disk partition on the same physical drive, then all are working correctly.

SMART and temp data are provided at the entire physical drive level because those are drive level parameters.

Similarly, if you created a virtual disk in RAM, such drive data, and how they apply toward impending failure and failure prediction/drive replacement would be meaningless.

edit-add ref quote

peeee jayyyyy Feb 05, 2008, 09:41am EST Report Abuse
>> Re: SpeedFan not working for me...

peeee jayyyyy Feb 05, 2008, 09:51am EST Report Abuse
>> Re: SpeedFan not working for me...
tx for replying john aldrich...
but i dont know what the hell you talking about... i just made a partition with partition magic and created a d drive... i discovered the problem, ie. the difference between the 2 drives... drive c had 2 downloads for this laptop on it from toshiba ... acpi common modules and also toshiba utilities / hwsetup thing ... which allows you to do some stuff like change the boot sequence... for some reason i put it on drive d too yesterday and the speedfan detected a fan... it must be something in the common modules d/l that allows speedfan or helps it find a fan to adjust speed on... the acpi common modules must be installed to be able to install the utility / hwsetup thing ... tx anyway

peeee jayyyyy Feb 05, 2008, 10:04am EST Report Abuse
>> Re: SpeedFan not working for me...
see if your computer maker has an acpi common modules d/l on its site...
i tried for months, since last october to make speedfan detect a fan and put a little box on the readings tab with up/ down percentage arrows for fan speed on a drive d that i created back then... i discovered yesterday after downloading the acpi common modules, ( a prerequsite for the utility program for this laptop ), which i also downloaded from toshiba, that the little fan speed control box appeared... this utility program and modules has been on drive c for 2 years where speedfan worked fine... i tried downloading every model of speedfan i could for drive d to get the little box without success untill i got the common modules on drive d ... good luck...

mothow Feb 05, 2008, 10:12am EST Report Abuse
>> Re: SpeedFan not working for me...
I never liked speedfan and i refuse to use it .Its got to many flaws and bugs.Since you have a DFI board you can use ITE. ITE. is really good program(DFI got this program right)and it controls the fans on your system just like speed is suppose to do but doesnt 99% of the time
Just use ITE...............................SPEEDFAN SUCKS

ASRock Z97 Extreme 4 / i7 4790K / Corsair H80i / 4x4GB Crucial Ballistix Smart Tracer DDR3 1600 / 1TB Western Digital Caviar Black / 240GB Mushkin Chronos Deluxe SSD / 2x Evga GTX 670 FTW 2GB in SLI / Sound Blaster Recon3D Fatal1ty / Corsair HX1000w
john albrich Feb 05, 2008, 01:17pm EST Report Abuse
>> Re: SpeedFan not working for me...
Mothow said:
I never liked speedfan and i refuse to use it .Its got to many flaws and bugs....Just use ITE...............................SPEEDFAN SUCKS

I've used speedfan on multiple computers with great success.

Speedfan has worked on systems for me where:
MBM5. . .fails
Everest.. fails
PCAlert4 fails

I think the more appropriate advice would be to use the utility that works best for your needs and provides the functionality you require. If one utility doesn't work on or meet your needs for your particular motherboard/system, use another. Cost is also another consideration.

Freeware Speedfan provides a very high level of flexibility and functionality and is relatively compact.

edit to add-
However, if there's a free monitoring/control utility specifically designed for your motherboard by or for the manufacturer, and it reliably does everything you need it to do on the OS you're using, that is probably the best choice.

edit to add 201104242140GMT:
After EdwinIsCool's post re-activated this old-old thread, I decided to provide additional info re: my 'edit to add-' comment above. Here's the new info.
Here's an example of a situation where even the motherboard MANUFACTURER'S CPU temperature reporting utility DOES NOT WORK.
I recently bought a GA880-GMA-UD2H motherboard. Gigabyte provides BIOS functionality and a utility called 'EasyTune' that among other things monitors the CPU and 'system' temps. During testing, I installed a Sempron 140 single-core CPU and both BIOS and EasyTune correctly report the CPU's temperature.
However...when you unlock the 2nd core both BIOS and EasyTune become UNABLE to correctly report the CPU temperature and it's set to 0C.
At the same time, Speedfan PROPERLY reports both core individual temperatures. This is apparently because when you unlock the 2nd core, the CPU no longer updates the primary temp sensor on the CPU. It's set to 0. This is widely known.
However what is not widely known is that the CPU's individual core temps ARE available to Speedfan as 'temp2' and 'temp3'. Other programs may also be able to report these parmeters as long as they scan the sensor buses during initialization.
But these 2 'core temp' parms are NOT used by BIOS or EasyTune. So, without Speedfan (or its equiv) I would be unable to monitor any CPU temps once the 2nd core was unlocked.
Interestingly, even though BIOS and EasyTune can't report ANY CPU temp, the CPU fan speed is STILL adjusted when the temperature increases per the parameter profile you setup in EasyTune.
So while neither BIOS nor EasyTune report any CPU temp, one/both IS still monitoring the temp of at least one of the CPU temp parameters and adjusting the CPU fan speed up and down as needed to keep the CPU cool. For more info on this situation, see my thread

Edwin isCool Apr 24, 2011, 02:37pm EDT Report Abuse
>> Re: SpeedFan not working for me...
Speedfan 4.43

Edwin isCool Apr 24, 2011, 02:44pm EDT Report Abuse
>> Re: SpeedFan not working for me...
what you need to do to get speed-fan working is...
1) click the configure button.
2) select advanced tab.
3) look for chip, and select the drop down arrow next to it.
4) if more then one option appears on the drop down menu. look at all of them until you see the one that has something that says PWM # mode.
5) Change all the (PWM # mode) values to software controlled. (dont forget to click on the check boxes that say "remember it" after you change each of the values.)

I hope this helps.

Stellmaszek Dec 25, 2012, 01:01pm EST Report Abuse
>> Re: SpeedFan not working for me...



  Topic Tools 
RSS UpdatesRSS Updates

  Related Articles 

A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.