Please register or login. There are 0 registered and 906 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s August 12 - 05:34pm EDT 
Hardware Analysis
Forums Product Prices

  Latest Topics 

More >>


  You Are Here: 
/ Forums / Networking / Wireless /

  Solution for MTU problem of Comcast Netgear CG814WG gateway router 
 Date Written 
Dr. Peaceful Jan 29, 2011, 11:20am EST Report Abuse
I am posting this solution so people out there can search and find it. It's a network problem not easy to diagnose. You can find pieces of the solution out there. I am summarizing them all here.

The Problem:
So, I was doing family "IT support" again. ;) One of my relatives was having a strange wireless connectivity problem with her cable network. When connected with the wireless network, she could only browse google but nothing else.

The ISP is Comcast. The coax cable goes direct to the back of a Comcast issued Netgear CG814WG gateway / modem router, which provides the wired and wireless network. No problem with wire network, just wireless.

It took me a while through the process of elimination and solution searching from the net to finally figured out the cause and fixed it. At first I thought may be just the firewall security software (Norton) in her Vista laptop blocking access. Then I thought may be the wireless mini card in her laptop was faulty. But then I tried another PC (WinXP, different firewall software and wireless adapter), the same problem occurred. So the problem was not on the computer side, it's from the router.

The Cause:
Cheap and outdated router! The CG814WG may look like a normal Netgear router with it silver exterior. But its firmware is a customized Comcast firmware. The firmware provides not a whole lot of features. The wireless was set to WPA security. Turned out that was the culprit of the whole problem. While the router is ok with WEP, there's limitations when using WPA.

My hypothesis is that when WPA is enable in the router, some how it has a limitation on MTU size. Her PC was having a MTU of 1500. When requesting a page from a website, the PC and the website negotiate for an appropriate MTU. Most website will just send packets with MTU 1500, which when goes through the router, it fragments the packets and lost connection to the website. Only a few websites, such as google, set their MTU to lower than 1500, so their packets goes through the router successfully.

The Solution:
Reset the MTU in the PC to lower than 1500. I did the following in her Vista PC, which should work for Win7 as well.

1. Bring up the command prompt (cmd.exe) in administrative mode.
2. Type this "netsh interface ipv4 show subinterfaces" to show all your network interfaces. Take note on the subinterface number of your wireless adapter.
3. Type this "netsh interface ipv4 set subinterface interface=? mtu=1492 store=persistent", where ? is your wireless subinterface number.

For WinXP and below, you have to muck around in the registry to change MTU. Or just download Dr. TCP to do it ( ).

Other Work-arounds:
Call up the cable tech support is not a solution, they are unlike to admit its their router's problem. In fact, my relative did, and they blame her computer! Don't waste your time. Use the solution above or you can use the work-arounds below.

1. You can use WEP instead of WPA, but you're sacrificing security.
2. Call up the cable ISP and ask to substitute their modem router with only a cable modem (no router). Then to go buy a better wireless router of your choice.

Hope this helps!

Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
Suspended User Jan 29, 2011, 11:49am EST Report Abuse
>> Re: Solution for MTU problem of Comcast Netgear CG814WG gateway router
Wow, how old was the router?

Good work Dr!

Interesting problem

Joshua Marius, LeThe Jan 31, 2011, 11:08am EST Report Abuse
>> Re: Solution for MTU problem of Comcast Netgear CG814WG gateway router

Good stuff! Thanks for sharing.

Joshua Marius
Windows 7 Ultimate x64 SP1
Intel Core i5-2500K
Intel SSDSC2CW180A3 180 GB
RAID 1: Seagate ST3750528AS 750 GB
CORSAIR Vengeance 8 GB DDR3 1600
eVGA GeForce 8800 GTS
G. G. Jan 31, 2011, 05:54pm EST Report Abuse
>> Re: Solution for MTU problem of Comcast Netgear CG814WG gateway router
Try this out...

Click on start button to the Tweak tester II

With the results.... pick the lower number and enter it into the MTU setting of your router. Hope this helps out.


Dr. Peaceful Feb 01, 2011, 08:15pm EST Report Abuse
>> Re: Solution for MTU problem of Comcast Netgear CG814WG gateway router
Missed your comment earlier G.G. Nice tweak to determine optimum MTU, but the problem is the MTU setting is nowhere to be found in that router's firmware!

Nitto Joseph Feb 17, 2012, 12:20pm EST Report Abuse
>> Re: Solution Netgear CG814WG gateway router WPA issue
Hi All,

WPA will not work on the device.. But when I switched to WPA2-Personal with AES encryption, it worked cool..

Well the router is crap, but if you already bought it, why not use this alternative?

Dr. Peaceful Feb 17, 2012, 02:07pm EST Report Abuse
>> Re: Solution for MTU problem of Comcast Netgear CG814WG gateway router
Thanks for the reply. But as far as I knew when I was troubleshooting this problem, WPA2 was not in the list of options in the CG814WG router admin settings. Only WEP or WPA were available. May be they had a firmware upgrade since. But still I would advice to avoid this outdated router as much as possible! It's not even compatible with DD-WRT, so you're stuck with the ISP's crappy firmware. I felt sorry for those who got ripped off for buying or renting this router.

There are many newer gateway routers available from this ISP, either ask for those or get your own. If you're leasing the equipment from them, be aware that: one, it's not yours, so you need to pay rent for it and you can not do any potentially irreversible modification to it (e.g. flashing with DD-WRT) without violating the agreement; two, it may use some special IP, password, or firmware (e.g. SMC gateway uses unusual IP of, so it may be harder for you to get into the admin settings and sometimes restrict you to rely on their tech support / service.

If you're tech savvy enough, I would highly recommend to get your own modem / router / gateway router, instead of using theirs. It would save you a bunch of money in the long run, not needing to pay the monthly rent for their equipment. It would allow you to get the hardware with the exact specs and price range you need, rather than choosing from a limited list of available (and likely used) equipment. It would be much easier and more freedom for you to administer your own network, since it's your hardware to mess with!

Just my 2 cents.

Manvel T Mar 01, 2012, 10:32pm EST Report Abuse
>> Re: Solution for MTU problem of Comcast Netgear CG814WG gateway router
Thank you SO much for your help. I frequently study at my friend's house with my laptop and was always forced to hook up a cable to my laptop in order to use the internet cuz I had the exact same problem with wireless that your friend experienced. He also uses the Netgear CG814WG wireless cable modem gateway. I tried calling Time Warner for assistance and they told me it must have been my laptop (HP). I called HP and re-installed all of the drivers for my wifi but nothing helped. I then tried calling Netgear for assistance and they wanted me to pay around $130 for assistance as the modem's 3 month warranty had expired (douches!).

I'm on a windows 7 and had to slightly alter the code I entered in cmd cuz it wouldn't accept the format you had written. This is what I used and it was successful:

netsh interface ipv4 set subinterface "NAME OF SUBINTERFACE GOES HERE" mtu=1492 store=persistent

I used your first code to get the name of the subinterface, which is "Wireless Network Connection" so I typed that in with the quotation marks around it and it worked.
Now I hope this won't interfere with my wireless connection at home (which I doubt it will).



Karen Chavez Oct 27, 2012, 04:10am EDT Report Abuse
>> Re: Solution for MTU problem of Comcast Netgear CG814WG gateway router
thank you SOO much to Dr. Paz for putting all of this into one place I have spent countless hrs today researching this horrible headache of a router!! and nitto Joesph Yes, WPA-2 worked perfectly for me too!
Thanks again I can finally sleep now!



  Topic Tools 
RSS UpdatesRSS Updates

  Related Articles 

A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.