Please register or login. There are 0 registered and 686 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s September 30 - 11:28am EDT 
Hardware Analysis
Forums Product Prices

  Latest Topics 

More >>


  You Are Here: 
/ Forums / Networking / Wireless /

  Access Points won't let me connect to internet, how to fix? 
 Date Written 
Jon . Jul 20, 2012, 01:37pm EDT Report Abuse
Hey, long time member here (new account, cant recover password)

I'm trying to help this guy fix his network at his hotel. Networking is not my expertise and I've explained this to him, but he insists that I keep trying.

I can't figure out whats causing the issue. Here's the set up. Modem is connected to Primary router, Ethernet cable connects router to switch, switch connects all Access Points. Now, I know for a fact that the AP's were working before as I was able to connect and browse the web. He said as of last week no one was able to connect to the APs and browse, other than the Primary router. When attempting to connect to any of the AP's it shows "connection was unsuccessful, the network has limited or no connectivity" IPv4 no network access IPv6 no network access.

I've tried the simple, unplug and/or reset AP, didnt work. I've been able to get into the settings for a couple AP's and I think everything looks fine. I've temporarily replaced the switch to see if that was the problem, but nothing.

Everything is different brands, the Primary router is linksys WRT54GS, one of the APs is Linksys, the others are Intellinet brand.

Let me know what other information you need, I would like to get this done already, been working on it for hours. Thank you.

Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
john albrich Jul 20, 2012, 03:18pm EDT Report Abuse
>> Re: Access Points won't let me connect to internet, how to fix?
I'm going to assume you mostly focused on debugging the devices, verifying drivers, soft and hard resets, changing channels, that sort of thing...I'm also assuming they have a robust malware defense.

If you haven't done so, I'd examine the systems for any driver, program, and security updates that have occurred at or after the beginning of the problem symptoms. If there have been updates, then backup the system(s) and roll-back the items you think that most likely might cause a problem with WiFi (an example of an obvious candidate would be a router or WiFi adapter updated driver). Also, keep in mind that an AV program could have received an automatic update and subsequently quarantined various files that weren't previously considered a problem. That happened to me about a year ago or so and I only figured it out when I looked at the AV program's history log.

If a simple roll-back isn't feasible...and they have been making regular backups and keep an archive, you might try setting up a test environment with a few systems' OS's restored (from your backups) to the way they were prior to the problem surfacing, and determining whether or not the problem persists.

An relatively easy alternative that could be instructive, would be to set up a few machines from scratch, with a newly installed OS and just the bare minimum additional software installed. This would allow you to evaluate the basic network out while keeping the software and hardware environment as simple as possible.

You might also want to examine the environment to see if someone has installed or replaced RF gear that could substantially interfere with WiFi (new, perhaps higher power or different frequency cordless phones, wireless cameras, etc).

Jon . Jul 20, 2012, 03:28pm EDT Report Abuse
>> Re: Access Points won't let me connect to internet, how to fix?
I have been doing the debugging side of things. No updates have been installed or downloaded on any of the equipment. I'll have to check into the AV logs.

I think its been narrowed down to a faulty router though, as I tried to hardwire from the switch to the laptop and no connection. I tried to hardwire from the router to the laptop and still no connection, or maybe it was a fluke? I reboot the router, had to hardwire to get to configuration window, change the ssid back and remove password and was able to connect....

Now that last sentence makes me wonder, if just pulling the plug from the router caused it to lose its current SSID and add a default wifi password, could it be that the power went out when this all started and caused the router to default ALL settings? (this power outage thing was just made apparent to me by the owner)

john albrich Jul 20, 2012, 03:45pm EDT Report Abuse
>> Re: Access Points won't let me connect to internet, how to fix?
Jon . said:
...could it be that the power went out when this all started and caused the router to default ALL settings? (this power outage thing was just made apparent to me by the owner)

I thought you checked all the settings per your original post. However, re: power outages and memory...

Power outages/restorations often introduce sometimes very large spikes and surges on the AC lines. More than just the effect of the simple loss of power, those variations can affect the electronics in unpredictable ways, and can indeed include corrupting even flash or battery-backed-up memory. Depending on the device, if at power-up it determines the memory was corrupted (e.g. invalid checksum) it may restore default values.

And of course if to keep costs down the device doesn't use flash or backed-up RAM, but just stores the data in volatile RAM, the device always will load default data at power-up.

Jon . Jul 20, 2012, 04:01pm EDT Report Abuse
>> Re: Access Points won't let me connect to internet, how to fix?
I did, everything matched up with the APs so I guess ignore that last comment.

Dr. Peaceful Jul 20, 2012, 05:14pm EDT Report Abuse
>> Re: Access Points won't let me connect to internet, how to fix?
The probability of all APs failed at once is very little, so the problem has to come from either the main router or even the modem, as you've already found out.

As to what would cause a router to lose all previously stored configurations, I can think of 4 reasons, one already mentioned by John.
1. A power spike either caused damage to the electronic components in the router or at least caused the router to reset its flash memory, as John mentioned above.

2. The router is starting to go bad by itself (e.g. faulty component(s), reliability problems, or near end of product life). After all, the WRT54 is a very old router, the first model of it came out 2002!

3. Someone, read hacker(s), was able to hack into the router and reset it back to manufacturer settings. You mentioned this is a hotel, meaning this is probably a guest network, that opens up more potentials for intruders. It's also not unusual to see people leave their router with the default manufacturer password instead of changing it. That would make intrusion even easier, obviously.

4. The owner accidentally reset his own router, either unaware of he did that or just didn't want to tell you. ;)

Just my 2 cents, a proper guest network in a hotel (or any business for that matter) should be setup with devices that provide professional secure hotspot capability to ensure security of the network, as well as to protect the customers. Consumer grade APs and routers may not be able to isolate each connected client to itself, such that one client can potentially "peek" into another client or even into the main network devices. Also recommend to have a completely separate network service for the business network, if not already done so.

Edit: Just realized that Intellinet is the maker of Guestgate, so may be he's already a proper guest network. But still would be good to have separate networks for guest and business as suggested. Also, may be a good idea to change the SSID, as well as the router password, just in case.



  Topic Tools 
RSS UpdatesRSS Updates

  Related Articles 

A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.