Please register or login. There are 0 registered and 196 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s October 04 - 06:54am EDT 
Hardware Analysis
Forums Product Prices

  Latest Topics 

More >>


  You Are Here: 
/ Forums / Problem Products /

  Card reader doesn't read card, but lights up. USB port works... 
 Date Written 
kOrny Apr 07, 2013, 03:42pm EDT Report Abuse
Another weird one...

I took out a 15-in-one card reader w/ USB port 3.5" device from an old Gateway and put it into my desktop. It connects to the motherboard via USB pin connector. The USB port on the drive works fine, but the SD card reader doesn't.

When I put a card in, the drive lights up... but Windows doesn't see anything. When I reboot, the PC recognizes there is an SD card loaded because it prevents me from booting. Similar issue happens when I try to install/uninstall a driver, only the setup program freezes until I remove the card.

I tried the Windows loaded drivers as well as the drivers from Gateway support (Vista was the highest version they had), blown compressed air in the SD card slot, and tested multiple cards in separate computers. All I get is a light from the drive seeing the card inserted.

Any ideas? Thanks.

Want to enjoy fewer advertisements and more features? Click here to become a Hardware Analysis registered user.
john albrich Apr 07, 2013, 07:22pm EDT Report Abuse
>> Re: Card reader doesn't read card, but lights up. USB port works...
It might be the card(s) you're trying to use. Older card readers can have really low limits on maximum capacity. For example, I took one off an eMachines system and the largest card it could handle was 2GB before it caused problems. Sorry I can't remember the exact nature of the problems but I remember it wasn't intuitively obvious that it was capacity related. I had to pull an 256MB SD card from an old mobile to test the theory as all my other cards, memory sticks, etc. were >2GB and would cause probs.

edit to add:
of course, the USB port on the adapter worked was just a simple USB port extension from a built-in hub after all.

This is how I believe it was designed:

USBheader (motherboard)
USB hub (card reader interface)
| |
| |_1st USB port for USB devices/drive
|__2nd USB port to other card interfaces (SD port, MMC port, etc)

Perhaps each card slot interface in the reader gsts its own USB port off the could probably check the Device Manager details for USB Controllers to verify.

kOrny Apr 07, 2013, 08:09pm EDT Report Abuse
>> Re: Card reader doesn't read card, but lights up. USB port works...
hmm yeah you are maybe right. the card I am trying to use is a 4GB... but the card reader is at least 7 years old by now. oh well.


Dr. Peaceful Apr 08, 2013, 10:18am EDT Report Abuse
>> Re: Card reader doesn't read card, but lights up. USB port works...
Some of these 3.5" internal card reader / USB units require additional power from the floppy power plug or regular molex plug. Don't forget to plug that in, if it needs one. But given the age of the unit, I think it's more likely the capacity issue John mentioned.

Naveen Goud Apr 08, 2013, 04:32pm EDT Report Abuse
>> Re: Card reader doesn't read card, but lights up. USB port works...

Sometimes the card reader doesn't read the data on the SD card, but recognizes the card. There is a possibility that the SDcard pins are not bedding properly on the card reader pins. If you do not add the tail to the SD card and then insert, it will offer such problems. What i mean by the tail is that elongation, which is offered while the card is in a package. We usually remove that tail and then insert the card in our mobile phones or cameras.

There is a chance that the data on the SD card might be lost due to some reason and so the card reader is sensing the card to be empty.




Graham Strong Nov 30, 2014, 11:41am EST Report Abuse
>> Re: Card reader doesn't read card, but lights up. USB port works...
I know this is an old post, but I have posted the same problem with no answers!

A friend has a problem with his card reader in it does not recognise any cards, yet the USB socket works ok.

I changed the card reader for a second hand one I had spare and also a brand new one, all have the same problem. The card readers work ok on my machine.

On the MB are three header sets of pins and tried all three, but still have the problem.

NOW, here's the strange thing: If I try to format the SD card W7 says it's in use (why?) but format anyway. I say ok and it formats. I can rename the card name and copy files - no problem - BUT as soon as the computer is rebooted the original problem comes back.

There are no drivers missing in the hardware list. tried uninstalling and reboot but no change.

john albrich Dec 01, 2014, 07:20am EST Report Abuse
>> Re: Card reader doesn't read card, but lights up. USB port works...
Graham Strong said:
...BUT as soon as the computer is rebooted the original problem comes back.

When you say "rebooted" is that a power-off reboot or a soft "ctrl-alt-delete" reboot or front panel power button reboot or a PSU AC mains off/on reboot? (there's a difference between a 110VAC mains power-off vs. a front panel power-off. There could be a difference between the two computers in USB port power management. e.g. whether power is 100% removed from the USB ports when you "reboot". Can vary from motherboard to motherboard and can depend on user's "wake-from" settings.

Graham, a few separate tests you might try to further rule-out or see why operation is different on the two computers. These examine possible differences in USB power management and write-cache management.

Does the problem still occur if you did above, you format, write, then read memory card, and THEN for each test below...

1)...does same problem occur if you remove and reinsert the card without rebooting? Note: this relies on premise that (as far as I know) all card readers should automatically show any installed memory card as a "removable device". If it doesn't then that's a problem. Also, see if the memory card itself is listed as a "removable device" on both computers. If it doesn't, then that problem needs to be addressed first.

2)...if you reboot with the memory card installed in the card reader before you reboot, or if you already tried that, does it still occur if you remove the memory card before you reboot and then insert the memory card after you've verified the card reader is recognized. Again, this can help check if there's a power management difference between the two computers.

3...if you use the "Safely Remove Hardware" procedure, then when told it's "safe"...remove the memory card and wait 30 seconds...and then reinsert the memory card without rebooting.

It gets more complicated from there...
You might also examine the USB interface chipsets. Sometimes a USB device will work properly on one USB port[1] but not another because one device/motherboard/chipset manufacturer didn't properly implement the USB standard or it's a way downlevel interface chipset. Or, even just a "downwards" compatible implementation. Just because a device says "USB2.x" doesn't mean ALL USB functions will work 100% correctly on ALL USB2.x interfaces or when you use a USB2.x device on a USB3.x port and vice-versa. Depending on what you find, you might then search on the internet for known problems with the failing motherboard/device chipset.combinations.

[1]That can even apply when a computer has both USB2.x and USB3.x a difference in the USB2.x interface chipset and the USB3.x interface chipset used on the same computer.

Graham Strong Dec 02, 2014, 01:37pm EST Report Abuse
>> Re: Card reader doesn't read card, but lights up. USB port works...
Thanks John for your very detailed and informative reply.
I have noted all you say and until I see my friend (and his computer) again, cannot say if any of your ideas work.
The reboot I mentioned was a soft reboot by using 'restart' from Windows. I do understand what you say about the differences in power (except in the UK we use 230v not 110v but that's not an issue I know) switch off and count to 10 etc.
The problem occurred suddenly and has been overcome by using a USB card reader in the USB socket - which works fine !!
I'll report back in due course, but it may be a while.
Many thanks

Graham Strong Dec 06, 2014, 11:14am EST Report Abuse
>> Re: Card reader doesn't read card, but lights up. USB port works...
An (unusual) update on the problem.
This card reader business gets more difficult to comprehend as time progresses.
I visited my friend recently to sort out an email problem (he's using Incredimail), and uninstalled and reinstalled that. Whilst there deleted a couple of unwanted programs - one was Regcure (registry cleaner - trial copy) and removed a load of temporary files manually from the Windows and User directories.
Then attempted to try the options John listed, and the card reader worked !!
Maybe the temp. files or Regcure were causing the hiccup?
Many thanks to all, especially John (I made a note in case the problem recurs)
I know where to come next time !!



  Topic Tools 
RSS UpdatesRSS Updates

  Related Articles 

A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.