Please register or login. There are 0 registered and 740 anonymous users currently online. Current bandwidth usage: 326.30 kbit/s September 18 - 04:18am EDT 
Hardware Analysis
Forums Product Prices

  Latest Topics 

More >>


  You Are Here: 
/ Forums / Portable Hardware /

  Sony Vaio laptop will not power up after Bios update 
 Date Written 
John Parritt Jun 23, 2015, 12:18pm EDT Report Abuse

I downloaded a Bios update as recommended in Vaio care, for my VPCEB1C5E I believe it was R 0300Y8 dated 08/2010 although I am not certain.
I haven't downloaded this before as I was always a bit scared to do it!
I observed the warnings indicated on screen and proceeded with download, Immediately the cooling fan started up and after a while I noticed my Bullguard firewall popped up with a message that an .exe file was trying to gain access and would I allow it, by mistake I pressed the Do Not Allow key which I believe is the cause of the problem.
Then the screen changed with a blue button appearing indicating (I believe stating Restart or Finish) there was also a small window open which stated that an something was being added or altered which i cannot remember.
I pressed the blue button and the screen went black with fan still running at full speed.
It continued like this for 10 minutes with nothing happening, apart from the fan going, so I started pressing the power button but to no avail.
Then a blue screen came up stating that windows had shut down to prevent a dangerous failure, amongst other things and to try and restart in safe mode, The was also a fault code but i cannot remember it.
I tried pressing F8 and the power button again but still couldn't shut it down so in desperation I disconnected the power lead and removed the battery.
I re-installed the battery and power lead but it will NOT power up, there are also no lights showing it appears to be completely dead.
I have tried a power discharge re-set by removing battery and power lead and pressing power button for 30 secs but to no avail.
The battery was in good shape prior to this with a green indicator and fully charged.
Could anyone please advise what else I can do or does it need to be repaired.




  Topic Tools 
RSS UpdatesRSS Updates

  Related Articles 

A weekly newsletter featuring an editorial and a roundup of the latest articles, news and other interesting topics.

Please enter your email address below and click Subscribe.